[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sed segfaults

From: Stepan Kasal
Subject: Re: sed segfaults
Date: Fri, 7 Nov 2003 17:30:12 +0100
User-agent: Mutt/1.4.1i

Hello Fred,

On Thu, Nov 06, 2003 at 12:09:50PM -0800, Fred Reiss wrote:
> When I run sed on the attached input file with the following command line:
> sed -e 's/\'\''.*\'\''/foo/' input.txt
> sed segfaults.  I assume it's not supposed to do that.
> GNU sed version 4.0.5

thank you very much for your bug report.  I've verified the bug with 4.0.5,
which is the default on my Red Hat GNU/Linux system, this way:

$ echo xxx| sed "s/\'.*\'/foo/"
Segmentation fault

Then I tried sed-4.0.7, the current version.  It didn't segfault, but...

$ echo xxx| sed/sed "s/\'.*\'/foo/"

Then I copied reg* source files from GNU libc CVS to the directory
sed-4.0.7/lib/ and did "make clean; make" to rebuild sed.  Then:

$ echo xxx| sed/sed "s/\'.*\'/foo/"

Well, the efect of \' is undefined by POSIX, so sed is compliant as soon
as it doesn't segafult.  But the current behaviour is weird.

I'm sending cc of this mail to the sed maintainer: Paolo, can you look
at this issue?

Have a nice day,
        Stepan Kasal

reply via email to

[Prev in Thread] Current Thread [Next in Thread]