[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem with solaris 2.5.1 and gettext-0.12.1

From: Warren L Dodge
Subject: problem with solaris 2.5.1 and gettext-0.12.1
Date: Mon, 17 Nov 2003 13:25:23 -0800 (PST)

I got a copy of gettext-0.12.1.tar.gz and tried to install it on

Solaris 8
Solaris 2.5.1

It worked fin on Linux and Solaris 8

On Solaris 2.5.1 I get this error.

-I../../../gettext-0.12.1/gettext-runtime/lib -I.. -I. 
-I../../../gettext-0.12.1/gettext-runtime/lib -I.. -I../intl 
-I../../../gettext-0.12.1/gettext-runtime/lib/../intl -I../../gettext-tools/lib 
-I../../../gettext-0.12.1/gettext-runtime/lib/../../gettext-tools/lib    -g -O2 
-c ../../../gettext-0.12.1/gettext-runtime/lib/canonicalize.c
In file included from 
../../../gettext-0.12.1/gettext-tools/lib/canonicalize.c:90: conflicting types 
for `rpl_realpath'
 previous declaration of `rpl_realpath'
make[3]: *** [canonicalize.o] Error 1
make[3]: Leaving directory 

This is what is in the stdio.h file

extern char *realpath(char *, char *);

I am not sure if there is a problem with the gcc install or if there is a
collision in solaris 2.5.1

gettext-0.11.5 worked fine 

I had a similar problem with libiconv-1.9.1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]