[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: crosscompile to arm-atmel-uclinux problems

From: Bruno Haible
Subject: Re: crosscompile to arm-atmel-uclinux problems
Date: Mon, 9 May 2005 13:10:25 +0200
User-agent: KMail/1.5

Glenn Hessler wrote:
> I am trying to bld gettext 0.12.1 to uClinux 2.4 on Arm7tdmi.
> I run configure as follows:
> $ ./configure --host=arm-atmel-uclinux
> --prefix=/home/ghessler/uClinux/uClinux-dist/lib
> --exec_prefix=/home/ghessler/uClinux/uClinux-dist/romfs/usr
> --with-included-gettext --disable-nls
> CFLAGS=-D__linux__ -D__uClinux__ -D__ELF__ -DNO_MM -DCONFIG_CPU_AT75C220=1
>       -march=armv4 -mtune=arm7tdmi -nostdinc -fno-builtin -v
>       -I/home/ghessler/uClinux/uClinux-dist/linux-2.4.x/include
>       -I/opt/uClinux/toolchain/arm/2.95.3/lib/gcc-lib/arm-elf/2.95.3/include
>       -I/home/ghessler/uClinux/uClinux-dist/uClibc/include
> When I run make, I get the following undefined errors (and others):
>       ....
>       ../lib/libgrt.a(error.o): In function 'error_tail':
>       error.o: undefined reference to 'putc_unlocked'
>       error.o: undefined reference to 'fflush_unlocked'

Settings that affect the preprocessor should be given in CPPFLAGS, not in
CFLAGS. Here this would be

CPPFLAGS="-D__linux__ -D__uClinux__ -D__ELF__ -DNO_MM -DCONFIG_CPU_AT75C220=1

> How do I pass a library dir w/ "-L" to the arm-elf-gcc run from the gettext
> libtool.

Through the LDFLAGS variable set at configure time.

I hope, with this info, the *_unlocked linker errors go away.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]