[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GDBM] On x86 fails to read db created on armel and vice versa

From: Max Lapan
Subject: [GDBM] On x86 fails to read db created on armel and vice versa
Date: Sun, 23 Mar 2008 23:53:01 +0300
User-agent: Mutt/1.5.17+20080114 (2008-01-14)


Today I found strange problem with libgdbm, and not sure this is a bug
or feature. I have one small program which creates gdbm hash from set
of pictures and other program which will enumerate and optionally dump
them. When I run both programs on one one platform, they work
fine. But when I try to open hash file created on x86 box on armel
platform it failed to obtain most of the records. The same error I got
when I try to open DB created on armel using x86 box.

On both platforms I use 1.8.3-3 version from debian. I tried to
compile 1.8.3 without debian patches, but problem persists. I attached
archive with sources of both programs (dbm_dump and dbm_update) and
two databases x86.db and armel.db. Both databases built from one set
of files.

wbr, Max Lapan

Attachment: gdbm-bugreport.tar.gz
Description: Binary data

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]