[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GDBM] On x86 fails to read db created on armel and vice versa

From: Andreas Schwab
Subject: Re: [GDBM] On x86 fails to read db created on armel and vice versa
Date: Mon, 24 Mar 2008 09:30:03 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.1 (gnu/linux)

Max Lapan <address@hidden> writes:

> Today I found strange problem with libgdbm, and not sure this is a bug
> or feature. I have one small program which creates gdbm hash from set
> of pictures and other program which will enumerate and optionally dump
> them. When I run both programs on one one platform, they work
> fine. But when I try to open hash file created on x86 box on armel
> platform it failed to obtain most of the records. The same error I got
> when I try to open DB created on armel using x86 box.

The GDBM on-disk format is architecture dependent, you cannot share it
between different architectures.


Andreas Schwab, SuSE Labs, address@hidden
SuSE Linux Products GmbH, Maxfeldstraße 5, 90409 Nürnberg, Germany
PGP key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]