[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with MacOs installation latest version

From: Mohammad Akhlaghi
Subject: Re: problem with MacOs installation latest version
Date: Thu, 27 Oct 2022 00:01:23 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.4.0

Hi Giulia,

Can you send the file 'tests/test-suite.log' file (as it says in the red line after the messages). That file should contain the cause of the crash.

The failure is in the ConvertType program (when converting a FITS file to PDF; as the name suggests), so it seems to be a problem with Ghostscipt (that writes the PDF output). But hopefully, it should be clear in the contents of 'tests/test-suite.log' ;-).


On 10/26/22 21:37, Giulia Golini wrote:
Hi Mohammad,
Sorry, another problem...

I wanted to run build-astrometry-index (astrometry net) and it wasn't
working so I downloaded on my Mac all the dependencies that astrometry net
needs with homebrew ( I have a problem with wcslib). I managed
  to run it but after that, I had a problem with astfits: The gsl library
was not found (the latest version is 2.7.1).
I also tried to install the GSL library as described in the gnuastro book (
sect, but it is not working.
So what I did was to install gnuastro again with all the mandatory
dependencies updated. Result: after " make check -j8" I get the screenshot

[image: Schermata 2022-10-26 alle 20.14.23.png]

Do you have any idea of what is happening? Or alternatively, how can I help
you debug this?
I have tried with the previous gsl version (2.7) but still I have the same


reply via email to

[Prev in Thread] Current Thread [Next in Thread]