[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Compile: Solaris msgfmt and it.po

From: Holger
Subject: Re: [Bug-gnubg] Compile: Solaris msgfmt and it.po
Date: Fri, 15 Aug 2003 15:02:30 +0200

At 23:55 14.08.2003 +0200, Jim Segrave wrote:
On Thu 14 Aug 2003 (21:48 +0200), Holger wrote:
> At 19:01 14.08.03 +0200, Jim Segrave wrote:
> >On Thu 14 Aug 2003 (17:49 +0200), Holger wrote:
> >> I've built again on Solaris and it fails with:
> >>
> >> it.po:12432: end-of-line within string
> >> found 1 fatal errors
> >> gmake[3]: *** [it.gmo] Error 1
> >>
> >> The line concerned is this (the 2nd):
> >> msgid "Depth"
> >> msgstr "Profondit\xe0"
> >>
> >> \xe0 is an ? which seems to be a line-feed one line up. Changing it to
> >> "Profondita" ran well, but is of course not correct Italian.

> I didn't scan the file for other occurrences. After all it was the only
> thing causing an error.

There are 16 0xe0 characters in the current it.po. There are alos lots
of other \x character

This is indeed strange. But this occurrence is the only one of \xe0 at the end of the string.

I've tried a few things and msgstr "Profondit\xe0 " (with a space at the end) works and msgstr "Termina i rollouts ad una particolare profondità" at line 2050 obviously works, too.

I've commited a fix.

I don't suppoe you want to install gnu gettext. Mine gives:
msgfmt (GNU gettext) 0.11.4

I've found
msgfmt (GNU gettext) 0.10.35
but it fails with the same error.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]