[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnubg] compile and cvs problems

From: Misja Alma
Subject: [Bug-gnubg] compile and cvs problems
Date: Sun, 30 Nov 2003 10:00:19 +0100


I tried to check out the latest sources from cvs. But when I tried to
connect as user 'anoncvs' I get the message 'no such user exists'. Should I
use another username or is something wrong in my cvs settings? My connection
string is :pserver:address@hidden:/cvs

So I downloaded a snapshot and followed the instructions on the page 'how to
compile a new build of gnu..'. I have placed the makefiles and the sources
in a directory c:\gnubg. But when I run gnubgOld.bat I get a load of error
messages and gnubg-old.exe is not built.
The first message I get is 'cannot find c:\gnubg\*.o';
after that comes:
In file included from drawboard3d.c:30:
inc3d.h:120: parse error before "Material"
inc3d.h:121: parse error before '*' token
inc3d.h:122: parse error before '*' token
Then comes
In file included from drawboard3d.c:32:
shadow.h:27: parse error before '*' token
shadow.h:28: parse error before '*' token
Some others:
drawboard3d.c: In function `TidyShadows':
drawboard3d.c:149: structure has no member named `Occluders'
drawboard3d.c:149: `OCC_BOARD' undeclared (first use in this function)
drawboard3d.c:149: (Each undeclared identifier is reported only once
drawboard3d.c:149: for each function it appears in.)

drawboard3d.c:162: structure has no member named `pieceList'
drawboard3d.c:163: structure has no member named `diceList'
drawboard3d.c:164: structure has no member named `DCList'

All those messages seem to be about the 3d board, so I have donwloaded and
unpacked the 3d packages in the gnubg folder as well.
My OS is Windows 2000.
What am I doing wrong?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]