[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Fwd: Re: A couple 14.3 bugs

From: Jim Segrave
Subject: Re: [Bug-gnubg] Fwd: Re: A couple 14.3 bugs
Date: Sun, 25 Jul 2004 23:39:01 +0200
User-agent: Mutt/1.4.1i

On Sun 25 Jul 2004 (20:36 +0200), ?ystein Johansen wrote:
> Hash: SHA1
> Joern Thyssen wrote:
> | On Sun, Jul 25, 2004 at 07:41:56PM +0200, Jim Segrave wrote
> |
> |>I've just looked at the .jpg in the bug report. How do you get the
> |><player> cannot move in a dialog box?
> |>I can't reproduce this under FreeBSD, but I also can't get to a
> |>situation where I get a dialog box telling me I can't move. I suspect
> |>that this is crucial to reproducing the problem.
> |
> |
> | The "[..] cannot move" comes from a call to outputf. When outputx is
> | called the buffered lines from output* calls are written; if there is
> | just one line, it's written to the status line below the board; multiple
> | lines are written to a pop-up. Hence, for some reason, the "[..]
> cannot move"
> | must have been written twice within the same turn.
> I guess it comes from play.c line 994 in function ShowAutoMove. The only
> place I can find.
> I guess ShowAutoMove is called twice. Still guessing: It is the call to
> ShowAutoMove in line 4225 of play.c. At least that must be one of the
> calls. I'm still not in at the end of this bug. Anyone else?

I can't see any obvious path for this. I've tried using the posted
gnubgautorc, I've tried combinations of Tutor mode, automatic play,
different delays between moves, nothing I do ever generates the
message twice in one turn.

Jim Segrave           address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]