[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnubg] gnubg on amd64 architecture

From: Jim Segrave
Subject: [Bug-gnubg] gnubg on amd64 architecture
Date: Tue, 13 Feb 2007 11:21:24 +0100
User-agent: mutt-ng/devel-r804 (FreeBSD)

I just got a new laptop with an Intel Core2 Duo and tried building
gnubg there (gentoo Linux as FreeBSD can't currently support the
Radeon graphics chip nor the Intel sound chip :-(( )

I have a fix for the sse tests in neuralnet.c, which otherwise don't
compile (pushfl is not valid on this architecture, pushf pushes a 64
bit value, so the pop's must become popq's to 64 bit
registers). What's the best way of setting a #define so that
neuralnet.c can choose which assembler code to generate for 32 bit and
64 bit machines? #define ATHLON perhaps?

As a side note, when it wouldn't compile and before I found the AMD
instruction set documents, I tried building it with the -march=sse2
and -DUSE_SSE_VECTORIZE flags omitted (on a fresh fetch from cvs), yet
conf.h still had #define USE_SSE_VECTORISE 1, so the compile still
failed. What's the correct way of suppressing the sse code?

>From brief testing, the results of analysing a match with a CLI
invocation of gnubg gives virtually identical results as I was getting
on my 686 machine, so it looks like the sse code is working.

However, in GUI mode, it is segfaulting in RenderBoard, I think because
nStride is -324, which in turn appears to be because nSize is
-1. Anyone know what's happening here? It's not 3d related, as a
rebuild --without-board3d behaves the same way.

I have a core file, so I can provide additional details on request. 

Jim Segrave           address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]