[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] gnubg crash

From: wayne . lydecker
Subject: Re: [Bug-gnubg] gnubg crash
Date: Thu, 21 Jun 2007 14:57:54 -0700
User-agent: Thunderbird (X11/20070221)

I have not tried it in the 2D version, but I suspect that it will
work fine.  Apparently, it is an X11 thing.  My system is Redhat
Enterprise Linux 5 with all of the latest patches.  I did upgrade
the ATI graphics driver because the default driver was horribly
slow.  My system is a Dell Precision 490.

-- Wayne.

Michael Petch wrote:
This bug looks awfully like the one that plagued the X-Windows builds on
OS/X (With X11).

Does this happen if you run the 2d version? I'm also curious what OS?

On 6/21/07 2:25 PM, "address@hidden" <address@hidden>

In the Makefile, "CFLAGS = -g -O2", so it looks like debugging
is turned on.  However, when I type "gdb gnubg" and then type
"run --sync", after the crash I get:

The program 'gnubg' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
   (Details: serial 16381704 error_code 1 request_code 0 minor_code 0)
   (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)

Program exited with code 01.
(gdb) backtrace
No stack.

I tried again, but with setting a breakpoint at gdk_x_error. The
function was not found.  I suspect that I am not compiling with
debug, but I don't know how to enable it.


-- Wayne.

Christian Anthon wrote:
This is what I would do to track the bug down:

1) Install the debug info packages for glibc, glib and gtk and X.
2) Install the gnu debugger (gdb)
3) Make sure that the -g (or -ggdb) is turned on while compiling gnubg.
4) make install
5) run the following command 'gdb gnubg' (assuming /usr/local/bin is
in your path)
6) inside gdb type 'run --sync'
7) reproduce the bug
8) inside gdb type 'backtrace'
9) mail the output here.


On 6/18/07, address@hidden <address@hidden> wrote:
Christian Anthon wrote:
On 6/15/07, address@hidden <address@hidden>
Gnubg crashes at random times during play with the latest, and I don't
know what to do about it.  I compiled it myself on Redhat Enterprise 5
using gnubg-source-MAIN-20070426.tar.gz.  When it crashes, I get:

The program 'gnubg' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such
I think it is unlikely to be a gnubg bug, though I could be wrong. Are
you running a vanilla redhat, and is it fully up to date. Are other
gtk applications causing you grief?


Yes, plain redhat that is up-to-date.  I don't know which of
my applications use gtk, but I have had some weirdnesses on my
system.  The clock applet on the panel crashes daily on both
gnome and KDE, and both window managers occasional "reset", where
the screen momentarily goes blank and then all open windows are
redrawn on the screen (even those that were iconified).  I don't
suspect a bug in gnubg as much as I suspect that it doesn't
handle an "invalid request code" nicely.

The one thing I do that is out of the norm is I have two virtual
terminals that I can switch between using alt-ctrl-F8 and
alt-ctrl-f9.  I'm fairly certain that that is causing the clock
applet crashes.

Is there any debug output I can request from gnubg that can help
diagnose this problem?


-- Wayne.

Bug-gnubg mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]