[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: getloadavg and LIBOBJDIR

From: Bruno Haible
Subject: Re: getloadavg and LIBOBJDIR
Date: Mon, 25 Sep 2006 14:04:45 +0200
User-agent: KMail/1.9.1

Jim Meyering wrote:
> The problem that causes the coreutils build failure is due in part
> to the way the bootstrap script invokes gnulib-tool, then moves/links
> the resulting files into our canonical lib/ and m4/ directories.
> Since coreutils is perhaps unusual in doing things this way,
> ... * gl/modules/getloadavg.diff: New file.

Sorry about the problem; I had tested that "gnulib-tool --import"
and "gnulib-tool create-testdir" worked fine in the general case only.

Thanks for fixing it in coreutils. This is precisely the kind of special
cases for which the .diff files make sense: when every other way to fix
it leads to more hassles.

> Confusingly, the diagnostic says ./lib/getloadavg.c is missing,

Oops, fixed it now.


--- getloadavg.m4       22 Sep 2006 12:47:55 -0000      1.18
+++ getloadavg.m4       25 Sep 2006 11:58:08 -0000      1.19
@@ -17,7 +17,7 @@
 # Make sure getloadavg.c is where it belongs, at configure-time.
 test -f "$srcdir/$1/getloadavg.c" ||
-  AC_MSG_ERROR([$srcdir/$ac_config_libobj_dir/getloadavg.c is missing])
+  AC_MSG_ERROR([$srcdir/$1/getloadavg.c is missing])

reply via email to

[Prev in Thread] Current Thread [Next in Thread]