[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: snapshot in preparation for m4 1.4.12

From: Eric Blake
Subject: Re: snapshot in preparation for m4 1.4.12
Date: Wed, 13 Aug 2008 06:05:53 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20080708 Thunderbird/ Mnenhy/

Hash: SHA1

According to Tom G. Christensen on 8/9/2008 6:41 AM:

Hello Tom,

Thanks for the report, and sorry for my delay in responding,

| On Irix 6.5.30 I see gnulib test failures:
| ./test-c-stack.sh[7]: 12954353 Memory fault(coredump)
| FAIL: test-c-stack.sh
| FAIL: test-c-stack2.sh

Are you in a position to help debug these?  Have you also tried installing

| test-signbit.c:149: assertion failed
| /bin/sh[10]: 13018421 Abort(coredump)
| FAIL: test-signbit
| Compiler is MIPSpro 7.4.4m
| On Irix 6.2 I also see problems in gnulib:
| cc-1241 cc: ERROR File = test-c-stack.c, Line = 59
|   A declaration cannot appear after an executable statement in a block.
|      struct rlimit rl;
|      ^

Previously reported, now fixed.

| After fixing the build failure I see these test failures:
| Bus error - core dumped
| FAIL: test-c-stack.sh

Ouch.  It looks like the stack overflow handler is causing unaligned
access.  Are you in a position to help debug?  Again, have you tried

| test-vasprintf-posix.c:1338: assertion failed
| /bin/ksh[10]: 14207 Abort(coredump)
| FAIL: test-vasprintf-posix
| The vasprintf-posix problem is still the loss of the '-' sign.
| Attempts to find a solution seems to have stalled after my post here:
| http://lists.gnu.org/archive/html/bug-gnulib/2008-04/msg00195.html
| Compiler is MIPSpro 7.3.0
| On Irix 5.3 the compilation fails early:
| source='fatal-signal.c' object='fatal-signal.o' libtool=no \
|         DEPDIR=.deps depmode=sgi /bin/ksh ../build-aux/depcomp \
|         cc  -I.   -I/usr/tgcware/include  -g -c fatal-signal.c
| cfe: Error: ./sig-handler.h, line 39: 'sa_sigaction' undefined;
reoccurrences will not be reported.
|      return (sa_handler_t) a->sa_sigaction;

Weird.  So Irix 5.3 has sigaction, but not sa_sigaction?  Can you please
post the definition of struct sigaction from <signal.h>?

| Full logs for all builds available at http://jupiterrise.com/tmp

I also noticed some compiler warnings in these logs, such as unused

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.9 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


reply via email to

[Prev in Thread] Current Thread [Next in Thread]