[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build failures (tcgetsid issue)

From: Simon Josefsson
Subject: Re: build failures (tcgetsid issue)
Date: Tue, 09 Aug 2011 08:50:22 +0200
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/23.2 (gnu/linux)

Bruno Haible <address@hidden> writes:

> Simon Josefsson wrote:
>> ./config.log contains the content below.  What's interesting is
>> that there is no #include <termios.h> which I believe is needed?
> Good point. I'm applying the patches below, that fixes it.

Thank you!  I will test.

>> The gltests/config.log file contains:
>> configure:30414: checking whether tcgetsid is declared
>> configure:30414: result: yes
>> however ./config.log contains the content below.
> Really bizarre. I tried the same thing on a glibc/Linux system, and got
> twice.

Did you run the exact same command as I did?  Just testing the
'tcgetsid' module is not sufficient, then it works as expected.  It only
happened when I tried a build of (almost) all gnulib modules.

>> maybe other headers are
>> enabled there, and the tcgetsid prototype gets defined indirectly.
> The only glibc header that includes <termios.h> is <pty.h>, which is not
> included by the test program. Are different gcc options enabled in . and
> gltests?

Nope, I just ran ./configure -C && make in the directory created by

rm -rf m && ./gnulib-tool --create-testdir --with-tests --dir m 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]