[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] maint.mk: let packages tweak sc_po_check pattern

From: Eric Blake
Subject: Re: [PATCH] maint.mk: let packages tweak sc_po_check pattern
Date: Mon, 29 Oct 2012 14:57:33 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20121016 Thunderbird/16.0.1

On 10/28/2012 02:06 AM, Jim Meyering wrote:
> Eric Blake wrote:
>> libosinfo wants to look for XML files with translation markers
>> of the form <_name>string to translate</_name>.  Rather than
>> globally adding this to the regex, I thought it would be easier
>> to make it possible for cfg.mk to override the default pattern.
>> https://www.redhat.com/archives/virt-tools-list/2012-October/msg00270.html
>> * top/maint.mk (sc_po_check): Add files-with-translation, to allow
>> finding files with other translation markers.
> That's clearly adding a new knob that projects like libosinfo can use
> and making no other change.
> ACK.
> However, that new variable name doesn't tell me as much as I'd like
> about its function.  How about changing it to indicate that this new
> variable is a regular expression?  We haven't been consistent with
> RE-related variable names, with -regex, _..._re, _re_, _RE, _match,
> -regexp, (I suppose it's the usual tension between not wanting to use
> _regular_expression or, heaven forbid, _extended_regular_expression,
> and the obtuseness of _RE or _ERE) but since we already have this:
>     # A regexp matching function names like "error" that may be used
>     # to emit translatable messages.
>     _gl_translatable_diag_func_re ?= error
> I suggest the following.
> Besides, adding a "_" prefix is more name-space friendly.

To some extent, so is using '-', as '-' does not appear in portable
'automake' rules (but that may not hold for much longer, if automake-ng
gains popularity).

>>From 4e0b109267214af6a5b56431a7403b6db4b8dddc Mon Sep 17 00:00:00 2001
> From: Jim Meyering <address@hidden>
> Date: Sun, 28 Oct 2012 08:38:09 +0100
> Subject: [PATCH] maint.mk: rename a new configurable variable
> * top/maint.mk (_gl_translatable_string_re): Rename from
> translation-markers: _gl_ prefix to insulate from user Makefile code,
> and the _re suffix to inform that it's a regular expression.

At any rate, sure, this change is fine.

Eric Blake   address@hidden    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]