[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #35580] bootstrap is not portable to OpenBSD

From: Gary V. Vaughan
Subject: Re: [bug #35580] bootstrap is not portable to OpenBSD
Date: Sun, 11 Aug 2013 14:57:02 +0700

Hi Mike,

Thank you for taking the time to try my script, and especially for the
great feed back.  Much appreciated!

On Aug 9, 2013, at 8:33 PM, Mike Miller <address@hidden> wrote:

> On Fri, Aug 9, 2013 at 10:36:42 +0700, Gary V. Vaughan wrote:
>> I'd be delighted to hear your feedback if you have any success in switching
>> to my rewrite [of gnulib bootstrap].
> I tried libtool/bootstrap in a test project on OpenBSD, I had a couple
> of problems.
> * if a buildreq does not have a required version, bootstrap still
> requires that the tool understands the --version option. It should
> skip calling func_get_version if _G_reqver is "-".

Good point, I'm just verifying a patch to that effect, which will propagate
into the various projects that use it in the coming weeks.  If you'd like a
copy with the recent changes already applied, just ask me off-list.

> The rest were simply conversion problems, not saying your script
> should be completely compatible,

When I wrote it in 2010, it was compatible, but once I had a version that
did everything I needed, I stopped tracking the gnulib version, so it has
likely diverged as time has passed.

> just things I ran into:
> * bootstrap.conf is not completely compatible, e.g. I had to change
> gnulib_tool_option_extras -> gnulib_tool_options. The user must
> include "--no-changelog" in bootstrap.conf if they want to keep that
> default option.

Thanks for the heads-up on that one… I've added a TODO to look at it.

> * buildreq list needs to be rewritten with URLs, if it's only 2
> columns instead of 3, errors ensue from trying to treat the wrong
> field as the wrong type.

This one too -- it should be a simple matter of checking whether a
third url-matching column exists and if not, warning that the enduser
will get sub-standard error messages if prerequisites are missing.

> * --skip-git instead of --no-git

Fixed by accepting either spelling.

Gary V. Vaughan (gary AT gnu DOT org)

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]