[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnulib-tool.py

From: Dmitry Selyutin
Subject: Re: gnulib-tool.py
Date: Tue, 5 Sep 2017 23:35:54 +0300

Hi Tim,

that's exactly what I've done today. I've just pushed some changes into repository; could you please try the latest version?
I didn't have time to integrate --no-changelog support yet (it seems it was either unimplemented before or appeared after project was completed).
Thank you for trying the Python version; please let me know if it works for you or if there are some other errors to be fixed.

P.S. I've started cleaning the entire code base, also rewriting some slow paths, but there is a lot of work to be done; stay tuned. :-)

2017-09-05 22:58 GMT+03:00 Tim Rühsen <address@hidden>:
Hi Dmitry,

I tried to remove some other options as well (as possible), but whatever
options there are, gnulib-tool.py doesn't like them.

The bootstrap.conf that I sent you is from project GNU Wget2.

Simply clone it (plus gnulib submodule) via
        git clone --recursive https://gitlab.com/gnuwget/wget2.git

And change to the pygnulib branch via
        cd gnulib
        git checkout pygnulib
        cd ..
        git commit -a -m "Use pygnulib"

Now edit ./bootstrap to use gnulib-tool.py and

The ./bootstrap script (also from gnulib) uses/loade ./bootstrap.conf.

Maybe that can help you with debugging (sorry, but I am absolutely not into

Regards, Tim

On Montag, 4. September 2017 23:18:29 CEST Dmitry Selyutin wrote:
> Hi Tim,
> thank you for reporting it. I strongly suspect that such behavior could be
> caused by invalid option processing. I've noticed that there are two
> "--import" directive, and the first one appears to have no arguments; could
> you please try omitting the very first "--import" directive?
> 4 сент. 2017 г. 10:29 ПП пользователь "Tim Rühsen" <address@hidden>
> написал:
> Hi,
> just tried out gnulib-tool, taking the very naive approach:
> - (in gnulib/) git checkout pygnulib
> - made a commit with this change
> - edited project's bootstrap to rename gnulib-tool into gnulib-tool.py
> - tried './bootstrap'.
> ./bootstrap: 920: ./bootstrap: gnulib/gnulib-tool.py: Permission denied
> This is easily fixed by 'chmod a+x gnulib/gnulib-tool.py'
> Second try resulted in:
> ./bootstrap: gnulib/gnulib-tool.py  --import --no-changelog --aux-dir build-
> aux --doc-base doc --lib libgnu --m4-base m4/ --source-base lib/
> --tests-base
> tests --local-dir gl --makefile-name=gnulib.mk --libtool --import ...
> usage: gnulib-tool.py --help
> gnulib/gnulib-tool.py: error: argument -i/--import: expected at least one
> argument
> Traceback (most recent call last):
>   File "gnulib/gnulib-tool.py", line 927, in <module>
>     errno = error.errno
> AttributeError: 'exceptions.SystemExit' object has no attribute 'errno'
> ./bootstrap: gnulib-tool failed
> Maybe I did something basically wrong !?
> Attached bootstrap.conf

With best regards,
Dmitry Selyutin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]