[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-GNUnet] GNUnet-0.8.0c dies with assertion failures

From: jayjwa
Subject: [bug-GNUnet] GNUnet-0.8.0c dies with assertion failures
Date: Tue, 22 Sep 2009 20:47:29 -0400
User-agent: Alpine 2.00 (LNX 1167 2008-08-23)

The gnunet daemon always dies with the following assertion errors:

Sep 22 20:23:09 FATAL: Internal error: assertion failed at mysql.c:427.
zsh: abort      gnunetd -u daemon -d

The gnunetd logfiles fill with these messages, but no other info.

Running the test suite also ends similarly:

Sep 22 20:20:57 `lt_dlopenext' failed for library
`libgnunetmodule_transport' with error: file not found
Sep 22 20:20:57 Internal error: assertion failed at handler.c:840.
/bin/sh: line 4: 13511 Aborted                 ${dir}$tst
FAIL: identitytest
1 of 1 tests failed
Please report to address@hidden

Which is odd because that file does exist at /usr/lib/GNUnet/libgnunetmodule_transport.so

Since then, I've updated to the most recent versions of MySQL and libmicrohttp and recompiled GNUnet. The problems still presists. The database server appears fine - I can login as the GNUnet user, work with the gnunet database, etc.

As a side note, I tried to sign up for bug tracking to better follow this issue, but there appears to be errors there too. I enter the confirmation URL, click 'update account' after supplying the requested info, and I only get the follow:

This account is protected. You are not allowed to access this until the
account protection is lifted.

Please use the "Back" button in your web browser to return to the previous
page. There you can correct whatever problems were identified in this error
or select another action. You can also click an option from the menu bar to
go directly to a new section.

Since I have no other way to send this, I'm using address@hidden


libmicrohttpd-0.4.2 (also tried with previous version)
mysql-5.1.39        (also tried with mysql-5.1.37)

Any help would be greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]