[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep under mingw

From: Richard Frith-Macdonald
Subject: Re: GNUstep under mingw
Date: Fri, 8 Mar 2002 07:31:04 +0000

On Thursday, March 7, 2002, at 11:52 PM, Fred Kiefer wrote:
The question is, why is this not working out for me? There is also the
question if as the mail from Richard seems to suggest I am just too dump
to get it running, or if there is a real problem. Actually I don't mind
that tone of voice, as I happen to know Richard, but to another user of
GNUstep faced with a similar problem I would not find this appropriate.

I certainly didn't mean to be offensive ... I was saying I had the same problem,
but a rebuild and install made it go away, and it hasn't returned.
I also made a guess that there might be a linking problem such that the library
needs to be installed before you link with it.  But that's just a guess.

GNUstep under mingw is basically un-tested Stephan Brandon and Richard did
get it running, but as far as I know there are not many other positive
reports on this. I tried to get it working using the complie-mingw script from Stephan, which I did adjust to my needs. And I also think that I have enough GNUstep (and MS Windows) experience to tell that if I run into trouble
something most be broken with GNUstep on MS Windows.

For me it was not possible to build it without downloading the libxml2,
as the compilation would just stop.

From your email it seemed you had just assumed that libxml was necessary,
if you said that you had tried without it I missed that. Certainly libxml
is absolutely *not* necessary - and the code should not even be trying to
use libxml unless you have it installed ... the configure script should
only turn on libxml usage if it finds it on the machine! If the configure
is saying that xml is present on the machine when it is not, thats a pretty
major bug.

As these might also be caused by the specific Windows version each of us
is using, here is mine: W2000 Professional with a current cygwin and a mingw
from November.

I haven't used either iconv or xml on my system ... and don't actually
know how to go about installing them to work with GNUstep mingw.
It's possible that these libraries are actually causing you problems -
and it might be worth trying a rebuild without them.

If you let me know where you got them and how you installed them, I
could try a rebuild with them on my windoze-xp system.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]