[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: -DSTRICT_OPENSTEP still not working.

From: Pascal Bourguignon
Subject: Re: -DSTRICT_OPENSTEP still not working.
Date: Sun, 10 Mar 2002 16:40:24 +0100 (CET)

> From: Richard Frith-Macdonald <richard@brainstorm.co.uk>
> Date: Sun, 10 Mar 2002 06:24:16 +0000
> On Sunday, March 10, 2002, at 06:02 AM, Pascal Bourguignon wrote:
> > Hello,
> >
> >
> > It   still  is  not   possible  to   compile  GNUstep   programs  with
> <snip>
> > In file included from 
> > /local/gnustep/System/Headers/Foundation/NSConnection.h:32,
> >                  from 
> > /local/gnustep/System/Headers/Foundation/Foundation.h:44,
> >                  from MapTreeTest_main.m:1:
> > /local/gnustep/System/Headers/Foundation/NSRunLoop.h:35: Cannot find 
> > protocol declaration for `GCFinalization'
> OK ... fixed that one.

Now, the problem  is in AppKit, about NSWindowDepth  which is declared
in  GSMethodTable.h, which  is included  in  NSGraphicsContext.h (line
88), but only when not STRICT_OPENSTEP. The whole NSGraphicsContext is
marked not STRICT_OPENSTEP...

g++ MapTreeTest_main.m -c \
-Wno-import -g -Wall -DUNIX -DSTRICT_OPENSTEP -fgnu-runtime -I. 
-IUtilities.subproj -I/local/users/pascal/firms/mappy/maptree/install 
-I/local/users/pascal/firms/mappy/maptree/install/maptree/interfaces -I. 
-fgnu-runtime -I/local/gnustep/System/Headers 
-I/local/gnustep/System/Headers/libxml -I/local/gnustep/System/Headers 
-I/home/pascal/GNUstep/Headers/gnustep -I/local/gnustep/Local/Headers/gnustep 
-I/home/pascal/GNUstep/Headers/ix86/linux-gnu -I/home/pascal/GNUstep/Headers 
-I/local/gnustep/Local/Headers/ix86/linux-gnu -I/local/gnustep/Local/Headers 
-I/local/gnustep/Network/Headers -I/local/gnustep/System/Headers/ix86/linux-gnu 
-I/local/gnustep/System/Headers \
       -o shared_obj/ix86/linux-gnu/gnu-gnu-gnu/MapTreeTest_main.o
In file included from /local/gnustep/System/Headers/AppKit/AppKit.h:43,
                 from MapTreeTest_main.m:2:
/local/gnustep/System/Headers/AppKit/NSGraphics.h:55: parse error before 
/local/gnustep/System/Headers/AppKit/NSGraphics.h:55: warning: type defaults to 
`int' in declaration of `_GSGrayBitValue'
/local/gnustep/System/Headers/AppKit/NSGraphics.h:55: warning: data definition 
has no type or storage class

Note  however  that  NSWindowDepth  is  an OpenStep  type  (listed  in

The fact that it is defined in GSMethodTable.h is questionable, but in
anycase it should be visible to NSGraphics.h even when STRICT_OPENSTEP
is defined...

__Pascal_Bourguignon__              (o_ Software patents are endangering
()  ASCII ribbon against html email //\ the computer industry all around
/\  and Microsoft attachments.      V_/ the world http://lpf.ai.mit.edu/
1962:DO20I=1.100  2001:my($f)=`fortune`;  http://petition.eurolinux.org/

Version: 3.1
GCS/IT d? s++:++(+++)>++ a C+++  UB+++L++++$S+X++++>$ P- L+++ E++ W++
N++ o-- K- w------ O- M++$ V PS+E++ Y++ PGP++ t+ 5? X+ R !tv b++(+)
DI+++ D++ G++ e+++ h+(++) r? y---? UF++++

reply via email to

[Prev in Thread] Current Thread [Next in Thread]