[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Some Gnustep problems, plus some workarounds

From: lukekendall
Subject: Some Gnustep problems, plus some workarounds
Date: Thu, 3 Oct 2002 21:26:47 +1000 (EST)

With some help from Adam Fedor, I have recently built the current
version of GNUstep on a Red Hat Linux 7.2 system.

# rpm -qa | grep gnustep
# uname -a
Linux posh 2.4.19 #2 Sun Sep 1 21:26:28 EST 2002 i686 unknown
# gcc --version
gcc (GCC) 3.2
Copyright (C) 2002 Free Software Foundation, Inc.

I had three problems afterwards.  I couldn't find a solution to the 3rd

1. Major one was that the installation, when creating the Services
   directory, the Defaults/.GNUstepDefaults file, the Library/Fonts
   directory (under ~/GNUstep), all were root owned and not owned by me.

   This sort of crippled things for me.  I compiled up GNUMail and
   tried it, but didn't get very far - it started up with no fonts.
   The errors reported were a bit misleading, too:

2002-10-02 08:54:27.908 make_services[5660] File NSDictionary.m: 458. In 
[GSMutableDictionary -initWithContentsOfFile:] Contents of file 
'/home/luke/GNUstep/Defaults/.GNUstepDefaults' does not contain a dictionary
2002-10-02 08:54:27.939 make_services[5660] Unable to load defaults from 

   In fact, the error was really "Permission denied", since the file(s)
   were all root-owned and 600 mode.  Looks like NSDictionary.m is not
   reporting the actual error.

   Once I plucked that error from the mass of others, it was easy enough
   to fix.

2. I had trouble with my dhcp-assigned IP address yesterday, and found
   I couldn't successfully run the /etc/rc.d/init.d/network script to
   restart the network.  I tracked it down to the fact that something
   had altered the PATH.  This was of course the /etc/profile.d/GNUstep.sh
   file.  The trouble was that its search paths are inserted in front of
   all others, and this must have been overriding some needed commands.

   I worked around this by simply modifying GNUstep.sh to do nothing
   when run by root:

    if [ "$USER" != "root" ]
        . /usr/GNUstep/System/Makefiles/GNUstep.sh

3. When running GNUMail, the pasteboard service wouldn't start:

    2002-10-02 10:49:31.947 GNUMail[2259] 
    I couldn't contact the pasteboard server for local host -
    so I'm attempting to to start one - which will take a few seconds.
    Trying to launch gpbs from /usr/GNUstep/System/Tools or a 
machine/operating-system subdirectory.
    It is recommended that you start the pasteboard server (gpbs) when
    your windowing system is started up.

   When I tried to run gpbs I got this error:
: /home/luke; gpbs
gpbs: error while loading shared libraries: libgnustep-gui.so.0: cannot open 
shared object file: No such file or directory

   That file does exist, however:
: /home/luke; locate libgnustep-gui

: /home/luke; ls -l 
lrwxrwxrwx    1 root     root           19 Sep 29 23:39 
/usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-gui.so -> 
lrwxrwxrwx    1 root     root           23 Sep 29 23:39 
/usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-gui.so.0 -> 
-rwxr-xr-x    1 root     root      3686742 Sep 29 23:38 

I also tried adding
/usr/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/ to my
LD_LIBRARY_PATH, but that didn't work either:


: /home/luke; gpbs
gpbs: Uncaught exception NSGenericException, reason: unable to register 

The same problem for gdnc:

: /home/luke; gdomap
: /home/luke; 
: /home/luke; ps ax | grep gdomap
 2279 ?        S      0:00 /usr/GNUstep/System/Tools/ix86/linux-gnu/gdomap
 2491 ttyp0    S      0:00 grep gdomap
: /home/luke; ps ax | grep gdnc  
 2494 ttyp0    S      0:00 grep gdnc
: /home/luke; gdnc
gdnc: error while loading shared libraries: libgnustep-base.so.1: cannot open 
shared object file: No such file or directory
: /home/luke; locate libgnustep-base.so.1 
: /home/luke; 
: /home/luke; gdnc
: /home/luke; gdnc: Uncaught exception NSGenericException, reason: unable to 
register GDNCServer


reply via email to

[Prev in Thread] Current Thread [Next in Thread]