bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bugs #11134] ./configure meaningless error or similar


From: Armando Di Cianno
Subject: Re: [bugs #11134] ./configure meaningless error or similar
Date: Thu, 25 Nov 2004 15:09:06 -0500

On 2004-11-25 15:13:53 -0500 Pupeno <address@hidden> wrote:
Summary:  ./configure meaningless error or similar

Original Submission: While running ./configure on a very recent gnustep-base (grabbed with cvs a couple of hours ago) I had this error:

checking for callback.h... no
checking "for forwarding callback in runtime"... yes
checking "FFI library usage"... libffi
checking for xml2-config... /usr/bin/xml2-config
checking for libxml - version >= 2.3.0... no
*** Could not run libxml test program, checking why...

You most likely do not want to build base without XML support.
For instance, MacOS-X compatible property lists require XML.
If you really want to build -base without XML support, add --disable-xml
to the configure arguments.
configure: error: Missing support for XML functionality.
address@hidden base $

I'm currently running gentoo and there's nothing with my xml, and in fact, the problem is with libffi, which is installed in /usr/lib/libffi/ and /usr/include/libffi. Maybe that's not nice and the ./configure script can't detect it, but even then, the error should be more accurte.

This is both a Gentoo bug and a GNUstep bug. Something is wrong with the Gentoo ebuild in the user's setup, but for some reason, if the --with-ffi configure option are incorrect ./configure bombs out with a libxml2 error, and not a with-ffi error.

__Armando





reply via email to

[Prev in Thread] Current Thread [Next in Thread]