[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with/questions about GNUstep-Startup 0.18.1

From: James Mahoney
Subject: Problems with/questions about GNUstep-Startup 0.18.1
Date: Mon, 18 Jun 2007 14:42:45 -0500

Hey everybody,

I am trying to install GNUstep with the Startup program version 0.18.1.
I am running Debian Etch on an IBM X30 laptop with a Pentium III, though
the entire system is probably not up to date with the 'stable' release
yet.  I am not using the Debian packages because I would like to try to
compile Etoile, which requires Base 1.14.  I have two questions about
problems that are arising.

1. This is minor, but the install script gives warnings W102 and W109
telling me my make version is not recent enough [W102] and that make
will not pass along the LD_LIBRARY_PATH and I should be root to install
[W109].  At line 32 in 00-config-output.log I get this:

        checking make version >
        3.75... /home/james/Desktop/gnustep-startup-0.18.1/configure:
        line 3762: --version: command not found
        checking broken make... broken

If I run "make --version" on my own, I get:
        GNU Make 3.81
        Copyright (C) 2006  Free Software Foundation, Inc.
        This is free software; see the source for copying conditions.
        There is NO warranty; not even for MERCHANTABILITY or FITNESS
        FOR A
        This program built for i486-pc-linux-gnu
This looks like a problem in the scripts somewhere.

As for the W109 which tells me to use sudo or to be root, I have run the
InstallGNUstep script both with sudo and as root, and still get the W109
warning.  Is this warning related to W102, given that "make --version"
is not being run by the script that is checking the versions and
functionality of everything?

2. The InstallGNUstep script will ignore these problems with make and
proceeds to tell me that I am ready to install GNUstep etc.  It prints
this list:

        This package installs these versions of the GNUstep libraries:
          GNUstep Make: 2.0.1
          GNUstep Base: 1.14.0
          GNUstep Gui: 0.12.0
I am wondering why GNUstep Back is not included in this list.  It seems
fruitless to go through with the installation if GNUstep Back will be
entirely missing.  I am attaching the log files from the build
directory.  Thank you for any help you can give, I am looking forward to
installing GNUstep and giving GNUmail and Etoile a whirl.


Attachment: 00-config.log
Description: Text Data

Attachment: 00-config-output.log
Description: Text Data

Attachment: installgnustep.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]