[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[NSThread detachWithSelector:] fails on SuSe 8.1

From: sECuRE
Subject: [NSThread detachWithSelector:] fails on SuSe 8.1
Date: Wed, 29 Aug 2007 21:50:28 +0200
User-agent: mutt-ng/devel-r804 (Linux)

GNUstep-base version 1.14.0
Operation system: SuSe Linux 8.1 with Kernel 2.4.19
GCC 3.2, GNUstep compiled by myself

I developed a GNUstep application on my workstation (Gentoo Linux, bleeding
edge) and wanted to port it onto one of our servers. Building GNUstep worked
fine on that old box (running since 5 years) but running the application did

When starting I got SIGABRT when using [NSThread detachWithSelector:]:
./obj/tool: Uncaught exception NSInternalInconsistencyException, reason: Unable 
to detach
thread (unknown error)

The reason for this is that libpthread wasn't linked against when building the
tool. After adding -lpthread to ADDITIONAL_TOOL_LIBS, it worked fine.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]