bug-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ProjectCenter Library project doesn't install headers


From: Lundberg, Johannes
Subject: Re: ProjectCenter Library project doesn't install headers
Date: Wed, 14 Nov 2012 17:32:58 +0900

I found a solution.

ProjectCenter adds "lib" before the project name to the variable "LIBRARY_NAME" in the GNUMakefile.
Removing "lib" and letting LIBRARY_NAME be the same as PACKAGE_NAME solves the problem and headers installs fine.
"lib" is still added to the filename of the installed library.

On Mon, Oct 1, 2012 at 3:07 PM, Germán A. Arias <address@hidden> wrote:
El lun, 01-10-2012 a las 11:42 +0900, Lundberg, Johannes escribió:
> Hi
>
> I have the latest version of GNUstep and ProjectCenter running on
> FreeBSD 9.0 32-bit.
>
> I have created a library using ProjectCenter and all works fine and it
> install in
> /usr/local/GNUstep/Local/
> Library/Libraries as it should when I run "# gmake install".
>
> However, the header files are not installed.
> The GNUMakefile generated by ProjectCenter contains the
> xxx_HEADER_FILES_INSTALL_DIR but no directory is created..
> xxx_HEADER_FILES contains my two header files I want to have
> installed.
>
> Thanks!

Maybe a bug on ProjectCenter. I don't have experience with libraries,
but for the moment check this GNUmakefile:

http://svn.gna.org/viewcvs/gnustep-nonfsf/frameworks/matharray/trunk/GNUmakefile?revision=42&view=markup

Hope this help.




--
Johannes Lundberg
BRILLIANTSERVICE CO., LTD.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]