[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling and running iceweasel

From: Johan Rudholm
Subject: Re: Compiling and running iceweasel
Date: Sun, 22 Jul 2007 16:20:44 +0200 (CEST)

Yes, tried that as well, with no better results (actually, exactly the same results).

On Sun, 22 Jul 2007, Giuseppe Scrivano wrote:

Have you already tried to compile and execute it without use the
debian paches?


Johan Rudholm <address@hidden> writes:


I hope this is the right place to ask, if not, perhaps someone could
tell me where to direct my question?

I'm trying to run my compiled version of iceweasel-, but the
browser window refuses to show itself. When running "strace -f" on the
program, it's clear that one of the children is stuck in a loop trying
to communicate with its parent:

[pid 18190] getppid()                   = 18189
[pid 18190] poll([{fd=9, events=POLLIN}], 1, 2000) = 0
[pid 18190] getppid()                   = 18189
[pid 18190] poll([{fd=9, events=POLLIN}], 1, 2000) = 0

and continuing like this until interrupted. fd 9 is the other end of a
pipe to the parent process.

Does anyone have a clue as to where to problem lies? Any and all help

Information about the build:

Linux xxx 2.6.18-4-686 #1 SMP Mon Mar 26 17:17:36 UTC 2007 i686 GNU/Linux

Sources[1] and patches[2] from Debian.

Linked against:

glibc 2.3.6
glib 2.12.12
xorg-libs git20070508
freetype 2.3.4
cairo 1.4.6
fontconfig git20070508
libpng 1.2.18
xorg-proto git20070508
expat 2.0.0
zlib 1.2.3
jpeg 6b
atk 1.19.3
pango 1.16.4
gtk+ 2.10.13
libidl 0.8.8
gcc 4.1.2
xorg-bitmaps git20070508

configure was run with:

--enable-optimize="-pipe -w -O2 -g -fno-strict-aliasing"


Kind regards,


Johan Rudholm                                wrfhf jrcg



Johan Rudholm                                wrfhf jrcg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]