[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU IceCat and use with the alternate profile option

From: inconnu
Subject: Re: GNU IceCat and use with the alternate profile option
Date: Sat, 01 Dec 2007 15:02:15 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-DK; rv: Gecko/20071130 Incognilla/1.1.7

Re the profile location: I'm puzzled by this problem, because using the configuration --with-user-appdir=.gnuzilla should set it correctly (this works for me in SeaMonkey, with which I'm more familiar). I've tried some grepping, hacking and compiling, and have had no luck.

Incidentally, I've never used Firefox on this install, so I had no ~/.mozilla/firefox directory.

Re the IceCat script: I've compiled several builds so far (trying to track down the profile problem) and I noticed icecat called run-mozilla.sh instead of run-icecat.sh. It also listed the profile location as .mozilla/icecat, though it used .mozilla/firefox. After using this script on the source and compiling, icecat correctly calls run-icecat.sh. It also correctly listed .gnuzilla/icecat as the profile directory, but does not use that directory. I noticed the moz_libdir in icecat is also still /usr/local/lib/firefox-

Here is the url to the icecat script from my last compile: http://incognu.com/downloads/icecat/icecat

Here are the relevant parts of the script I ran on the source:

ICECATBUILDROOT=/dev/shm/icecat- #edit as needed
# this I think makes the icecat script call for profile in correct location; however it does not use that location sed -i 's/.mozilla\/icecat/.gnuzilla\/icecat/g' $ICECATBUILDROOT/browser/app/Makefile.in

# this will make the icecat script call for run-icecat.sh instead of run-mozilla.sh; I know some are irrelevant sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/browser/app/mozilla.in sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/browser/installer/unix/packages-static sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/build/unix/unix.pkg
sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/config/config.mk
sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/directory/xpcom/tests/Makefile.in sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/embedding/config/readme.html sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/embedding/config/basebrowser-mac-macho sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/embedding/config/basebrowser-unix sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/embedding/config/basebrowser-qnx sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/extensions/java/xpcom/build/Makefile.in sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/extensions/java/xpcom/src/Makefile.in sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/extensions/python/xpcom/doc/configure.html sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/extensions/python/xpcom/doc/configure.html sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/extensions/xmlterm/scripts/xmlterm.spec sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/toolkit/mozapps/installer/packager.mk sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/toolkit/components/feeds/test/exectests.sh sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/tools/test-harness/xpcshell-simple/test_all.sh sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/webshell/tests/viewer/mozilla-viewer.sh sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/xpfe/bootstrap/mozilla.in sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/xpinstall/packager/packages-static-unix sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/xpinstall/packager/packages-unix sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/xpinstall/packager/unix/deliver.pl sed -i 's/run-mozilla.sh/run-icecat.sh/g' $ICECATBUILDROOT/xpinstall/packager/unix/config.it

# and this I think makes no difference:
sed -i 's/MOZ_APP_NAME=mozilla/MOZ_APP_NAME=gnuzilla/g' $ICECATBUILDROOT/configure sed -i 's/MOZ_APP_NAME=mozilla/MOZ_APP_NAME=gnuzilla/g' $ICECATBUILDROOT/configure.in

## still make -C xpinstall/packager creates pkg named firefox- ## still puts profile in .mozilla/firefox, though correct path is named in icecat
## icecat correctly calls run-icecat.sh
## icecat incorrectly lists libs as moz_libdir=/usr/local/lib/firefox
### end script

On 2007-11-30 22:08, Giuseppe Scrivano wrote:
address@hidden writes:

It won't run with a straight out swap but if the iceweasel script is
renamed to icecat and the run-iceweasel.sh references within are
changed to run-icecat.sh , it seems to run fine . Also,  the line
MOZ_USER_DIR=".mozilla/iceweasel" was changed to
MOZ_USER_DIR=".mozilla/icecat"  but I couldn't determine if that
change was required.
Can you please send me directly your file?

The other difference I ran across is  the new icecat-
version defaults to using profiles in the ~/.mozilla/firefox directory
whereas the previous iceweasel- version had created a new
~/.gnu/iceweasel directory which seems preferable but maybe was done
for compatibility between distros??
Are you sure you have your profiles in ~/.mozilla/firefox?  In the
.mozconfig file we are using to compile it, there is specified:
ac_add_options --with-user-appdir=.gnuzilla.  I have this directory
with profile information, can you check if it is present on your
machine too?

Is the creation and use of the ~/.gnu/icecat profile folder equivalent
something that can be accomplished without recompiling? If not, could
you point me to parameters or  source code sections which affects
this?  Thanks.
As I said you, this value was specified at compile time.  I don't know
if it is possible to choose another one at run time but I don't since
this location contains files used by Firefox/IceCat at startup.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]