[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Icecat / Gnash

From: Nigel Rumens
Subject: Icecat / Gnash
Date: Fri, 01 Feb 2008 07:34:11 +0000
User-agent: Thunderbird (X11/20071115)


Had a quick play with icecat and gnash.

Icecat - icecat- compiled from source tar distribution
Gnash downloaded latest version from cvs and compiled.

Tried playing a video form youtube and got:

xEmbed supported in this browser
GTK2 supported in this browser
NewStream: The full URL is http://www.youtube.com/active_sharing.swf
Closed 45files.
Starting process: /usr/local/bin/gtk-gnash -v -x 18875130 -j 550 -k 115 -u http://www.youtube.com/active_sharing.swf -U http://www.youtube.com/ -P bgcolor=#FFFFFF -P flashvars=t=Videos being watched right now... -P height=115 -P id=active_sharing -P name=active_sharing -P quality=high -P src=active_sharing.swf -P style= -P type=application/x-shockwave-flash -P width=550 -P wmode=opaque -
Forked successfully, child process PID is 19529
/usr/local/bin/gtk-gnash: /usr/local/lib/icecat- version `NSS_3.12' not found (required by /usr/lib64/libcurl.so.4)

Somthing to do with nss by the looks of it so re ran configure for icecat:-
./configure --enable-gui=gtk --with-system-nss

(--enablue-gui=gtk - 'cos I don't use kde)

Tried again and exactly the same thing happened

Then (I was feeling beligerant at the time!) moved /usr/local/lib/icecat- out of the way so it couldn't use it (seemed to be rebuilt even with --with-system-nss)......

....and hey presto I can watch videos on youtube with icecat/gnash.

Loads of whinge messages along the lines of:-

07:24:51: ACTIONSCRIPT ERROR: Reference to undefined member [string:seekBar_l] of object [gnash::sprite_instance(_level0.player.controller):0x2aaab41062e0] 19625] 07:24:51: ACTIONSCRIPT ERROR: -- set_member [undefined]._x=[number:0] on invalid object! 19625] 07:24:51: ACTIONSCRIPT ERROR: Reference to undefined member [string:seekBar_r] of object [gnash::sprite_instance(_level0.player.controller):0x2aaab41062e0]

But it works.

By the way system is Fedora 8 running on amd64

Posted this here as on the gnuzilla website it says:- It would be particularly helpful to test GNU IceCat with GNU Gnash <http://www.gnu.org/software/gnash/>.

So in case anyone is interested - that's the result of a very quick and VERY dirty test.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]