[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Need to edit Firefox 3.5 compatible extensions to install them in Ic

From: Figue
Subject: Re: Need to edit Firefox 3.5 compatible extensions to install them in IceCat
Date: Sat, 11 Jul 2009 18:26:41 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv: Gecko/20090710 Lightning/1.0pre Shredder/3.0b3pre

You're right Giuseppe.



Giuseppe Scrivano said the following on 11/07/09 18:24:

it is a nice hack to have it working quickly, but we don't want to break
compatibility with Firefox addons, it will be very silly to imagine
every addon will maintain a separate version just for us to use "-g1".


Figue<address@hidden>  writes:


try with

<!-- GNU IceCat -->




Giuseppe Scrivano said the following on 11/07/09 18:15:

I looked at the .xpi you sent me and I noticed this:


Is there any special reason why the langpack should work exactly on 3.5?
I think that it is a too strict requirement, why it shouldn't work on
3.5.1 or  I don't know if Firefox langpacks do the same, but it
seems a bit strange to me.

Anyway, I am going to change the versioning scheme for IceCat, I'll
remove the -gN suffix, we were using it to have more releases based on
the same Firefox version, but it never happened in reality.  IMO, drop
the suffix is better than introduce new changes in the library to handle
it or don't work with so many addons.


al3xu5 / dotcommon<address@hidden>   writes:

Il giorno venerdì 10/07/2009 19:52:35 CEST
Bruno Miguel<address@hidden>   ha scritto:

I know that a lot of Firefox extensions are not yet upgraded to
version 3.5. But some are. And I've been having some difficulties
installing some of them. Although maxversion is set to 3.5, I have to
change it to 3.6pre1 so it installs.

I've already reported this behavior with Firebug [1]. I'm using the
latest 1.4 beta version, which is, according to the info available in
addons.mozilla.org, Firefox 3.5 compatible (but it doesn't work,
unfortunately). Now, it happened with oxygen theme [2], which was
finally ported to the new Firefox version.

I checked the install.rdf and the max-version is 3.5. I didn't try to
install it with Firefox, but I assume it should install with no
problem. Yet, IceCat 3.5 doesn't allow installation.

Is there any problem in the browser identification?

I still have the same ("extension not compatible") problem with the
it.xpi langpack I have rebranded...

The addon maxversion is set to 3.5.

I am using the test GNU IceCat file from here:

Hope it helps


al3xu5 / dotcommon

Support free software! Join FSF: http://www.fsf.org/jf?referrer=7535
You will receive a bootable USB membership card with gNewSense Live!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]