[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling IceCat on mipsel

From: Federico Bruni
Subject: Re: compiling IceCat on mipsel
Date: Sun, 30 May 2010 23:15:53 +0200

On Sun, 2010-05-30 at 14:38 +0200, Giuseppe Scrivano wrote:
> Can you please try with the last source package?
> You can get it here:
> http://ftpmirror.gnu.org/gnuzilla/3.6.3/icecat-3.6.3.tar.xz
> Please let me know if you'll have problems with it.

Much better :)

Here are the missing dependencies I have found out running ./configure:

sudo aptitude install libdbus-glib-1-dev  libnotify-dev libasound2-dev
libidl-dev libiw-dev libxt-dev

Then the usual combo:
sudo make install

The build took approximately 4 hours and probably something went wrong.
I have these errors at the end of make:

collect2: ld returned 1 exit status
make[3]: *** [libxul.so] Error 1
make[3]: Leaving directory `/home/fede/src/icecat-3.6.3/toolkit/library'
make[2]: *** [libs_tier_toolkit] Error 2
make[2]: Leaving directory `/home/fede/src/icecat-3.6.3'
make[1]: *** [tier_toolkit] Error 2
make[1]: Leaving directory `/home/fede/src/icecat-3.6.3'
make: *** [default] Error 2

I've tried to install it anyway.
But I can't find the executable file in /usr/local.
I just have this broken link:

/usr/local/bin/icecat -> /usr/local/lib/icecat-3.6.3/icecat

ls /usr/local/lib/icecat-3.6.3/
chrome          libmozjs.so     libplc4.so       modules
components      libnspr4.so     libplds4.so      mozilla-xremote-client
defaults        libnss3.so      libsmime3.so     platform.ini
dictionaries    libnssckbi.so   libsoftokn3.chk  removed-files
greprefs        libnssdbm3.chk  libsoftokn3.so   res
libfreebl3.chk  libnssdbm3.so   libsqlite3.so    run-icecat.sh
libfreebl3.so   libnssutil3.so  libssl3.so

I've tried run-icecat.sh but it does not work:


run-icecat.sh: Cannot execute .

Please find attached config.log (maybe it can help you?).


# Just a note for newbies like me
Icecat 3.6.3 sources are available just as .tar.xz archives.
To decompress it, you need this program:

Compiling xz is very easy and quick.

Anyway when gNewSense 3 will be based on Squeeze, the package will be in
the repository.. so it will be as easy as:

aptitude install xz-utils

Type in a terminal:
unxz icecat-3.6.3.tar.xz
tar -xvf icecat-3.6.3.tar

Attachment: config.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]