[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU IceCat 6.0.2 released

From: Christophe Jarry
Subject: Re: GNU IceCat 6.0.2 released
Date: Sat, 17 Sep 2011 20:14:27 +0200


I tried to build icecat-5.0 on Loongson 2F under gNewSense metad, I think my
experience could help you so here is what I did.

The patches I used come from the IceWeasel-5.0 package from debian. I attached
them to this mail so that you can use them.

I first commented out the following line in .mozconfig as this line prevents
some images to be displayed in 3.6.x:

    ac_add_options --enable-optimize="-pipe -O3"


    ./configure && make

gives me the first error:

    ./assembler/jit/ExecutableAllocator.h:398:6: error: #error "The cacheFlush
support is missing on this platform."

I fixed this problem with:

    patch -Np1 <Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch
    cd js/src
    cd ../..

Then, another error message:

    ../../dist/include/nsIVariant.h:134:21: error: jspubtd.h: No such file or
    ../../dist/include/nsIVariant.h:222: error: ‘jsval’ has not been declared

I ran `make` once again and went through this problem. Then, still:

    ../../ipc/chromium/src/build/build_config.h:64:2: error: #error Please add
support for your architecture in build/build_config.h

So I did:

    patch -Np1 <Add-mips-hppa-ia64-s390-and-sparc-defines-in-ipc-chr.patch

Some time later, issuing `make` gives:

    xptcinvoke_mips64.cpp:44:2: error: #error "This code is for MIPS N32 only"

Here I am stuck. If your operating system is built for MIPS n32, you may go
through this, otherwise you most probably will have the same problem.


Attachment: Add-mips-hppa-ia64-s390-and-sparc-defines-in-ipc-chr.patch
Description: Text Data

Attachment: Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]