[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnuzilla] IceCat 13.0.1 compilation with Profile-Guided Optimizatio

From: Figue
Subject: [Bug-gnuzilla] IceCat 13.0.1 compilation with Profile-Guided Optimization
Date: Tue, 17 Jul 2012 11:30:55 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120616 Thunderbird/13.0.1


I'm trying to build IceCat with the Profile-Guided Optimization, explained in [1]. I'm doing the compilation with this parameter:

mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) $(OBJDIR)/_profile/pgo/profileserver.py'

And during the build I do this:

export MOZ_PGO=1
export DISPLAY=:99
Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
make -f client.mk build

It starts the virtual X (Xvfb) and launch an IceCat instance in order to generate the profiling data for the compiler. It seems that Xvfb is running fine (I can see the page http://localhost:8888/), but compilation stops at this point. Last IceCat releases are built fine.

This is the output I see when it stops:

MOZ_PGO_INSTRUMENTED=1 OBJDIR=obj-x86_64-unknown-linux-gnu JARLOG_DIR=obj-x86_64-unknown-linux-gnu/jarlog/en-US /usr/bin/python2 obj-x86_64-unknown-linux-gnu/_profile/pgo/profileserver.py 10 args: ['/home/figue/icecat/src/icecat-13.0.1/obj-x86_64-unknown-linux-gnu/dist/icecat/icecat-bin', '-no-remote', '-profile', '/home/figue/icecat/src/icecat-13.0.1/obj-x86_64-unknown-linux-gnu/_profile/pgo/pgoprofile/', 'http://localhost:8888/index.html']
INFO | automation.py | Application pid: 4135
Xlib:  extension "RANDR" missing on display ":99".
localhost.localdomain - - [16/Jul/2012 17:33:47] "GET /index.html HTTP/1.1" 200 - localhost.localdomain - - [16/Jul/2012 17:33:48] code 404, message File not found localhost.localdomain - - [16/Jul/2012 17:33:48] "GET /safebrowsing-dummy/newkey HTTP/1.1" 404 - localhost.localdomain - - [16/Jul/2012 17:33:49] "GET /favicon.ico HTTP/1.1" 200 - localhost.localdomain - - [16/Jul/2012 17:38:23] code 404, message File not found localhost.localdomain - - [16/Jul/2012 17:38:23] "GET /safebrowsing-dummy/newkey HTTP/1.1" 404 -

It seems that 404 is not important. I tried to build with GCC 4.7 and 4.6. Nothing changed. Tried many variations in the build process and several machines (i686 and x86_64), but I haven't more ideas. Has anyone been able to build IceCat with PGO?

Best regards

[1] https://developer.mozilla.org/en/Building_with_Profile-Guided_Optimization/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]