bug-gnuzilla
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnuzilla] [Bug] Icecat about dialog with french traduction


From: Narcis Garcia - GiLUG
Subject: Re: [Bug-gnuzilla] [Bug] Icecat about dialog with french traduction
Date: Mon, 14 Jan 2013 12:09:32 +0100

New version attached, now stable.
It's useful for more situations, and more regular.
It still doesn't remake the "About" dialog.

I'll leave the functionality as is, until somebody tells exact changes
to do to concrete files.


Al 13/01/13 23:41, En/na Loic J. Duros ha escrit:
> Narcis Garcia - GiLUG <address@hidden> writes:
> 
>> I've writen a script from scratch; see attachment.
>> At the moment it doesn't take care of the "About" dialog, but it's a
>> first version to test.
> 
> Hi Narcis:
> 
> Very nice job! I just ran the script on the Firefox langpacks for
> 17.0.1. After testing a few of them, it looks like they work, and
> without the errors I had with the previous script! I'm currently adding
> the new language packs to the ftp. They will be located at:
> ftp://ftp.gnu.org/gnu/gnuzilla/lang/17.0
> 
> Thanks for taking the time to write this script. One thing though, in
> order to be added to the IceCat codebase, we'd need a license notice in
> the file. You mention GNU GPL in the script, do you mean GPLv3+?
> If so, could you add a license notice to the file, as described here:
> http://www.gnu.org/licenses/gpl-howto.html
> 
> After this is done I can add your script to the repo for future
> uses. The old script didn't even have one, so it's good to address this
> issue early! :)
> 
> Loic
> 
> 
>>
>>
>> Al 13/01/13 18:33, En/na Loic J. Duros ha escrit:
>>>
>>> Hi all:
>>>
>>> There's a documented trail of errors with the language packs and the
>>> conversion script. We're looking for someone to work on the bash script
>>> that converts them and fix it. The latest version of the script can be
>>> found in the main bzr repo:
>>> http://bzr.savannah.gnu.org/lh/gnuzilla/icecat-latest/annotate/head:/icecat-tools/download.sh
>>>
>>> IIRC, currently the script just breaks some xml markup in the files, and
>>> it creates many errors.
>>>
>>> I have no time to look into this because my focus is on privacy and
>>> freedom enhancements (and they also need more volunteers.) That's why if
>>> someone would volunteer to fix it and take care of this issue going
>>> forward, it would be very helpful for the project.
>>>
>>> Anyone with bash scripting skills and good sed/awk knowledge or the will
>>> to learn these tools should be able to do this.
>>>
>>> As Luke mentioned, the Iceweasel-libre language packs may be your best
>>> bet at the moment. It may be useful to look how these langpacks are
>>> generated also (are the langpacks taken from Debian originally?)
>>>
>>> Thanks!
>>>
>>> Loic
>>>
>>>
>>>> Al 02/11/12 16:29, En/na S├ębastien ha escrit:
>>>>> If I install the french langpack, with the package manager or the GNU.org 
>>>>> archive, I obtain an error (see attachment).
>>>>>
>>>>> Freely,
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> http://gnuzilla.gnu.org
>>>
>>> --
>>> http://gnuzilla.gnu.org
>>>
>>
>> --
>> http://gnuzilla.gnu.org

Attachment: gnuzilla-convert-langpacks.zip
Description: Zip archive


reply via email to

[Prev in Thread] Current Thread [Next in Thread]