[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnuzilla] Can't seem to run Icecat 17 alongside Firefox 20 on Fedor

From: Julian
Subject: [Bug-gnuzilla] Can't seem to run Icecat 17 alongside Firefox 20 on Fedora 18.
Date: Tue, 30 Apr 2013 08:54:13 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130402 Thunderbird/17.0.5

I noticed that ever since I updated Fedora 18, which brought the Firefox version from 17 to 20, I get this message any time I try to run IceCat (which is the 64-bit binary from http://ftp.gnu.org/gnu/gnuzilla/17.0/, http://ftp.gnu.org/gnu/gnuzilla/17.0/icecat-17.0.1-64bit.tar.gz):

XPCOMGlueLoad error for file /home/julian/icecat-17.0.1/libxpcom.so:
/home/julian/icecat-17.0.1/libssl3.so: version `NSS_3.14' not found (required by /usr/lib64/xulrunner/libxul.so)
Couldn't load XPCOM.

I asked on a few IRC channels and got a response on #gnu, where we deduced that the problem is that, for some reason, IceCat is in some cases loading the system shared object files when it should be loading the shared object files contained in the IceCat directory.

We tried setting the environment variable LD_LIBRARY_PATH to the IceCat directory, but that made no difference. The same error occurred. I can also confirm that libxul.so is indeed in my IceCat directory.

The user on #gnu who helped me mentioned that, in the past, they had successfully installed a Firefox (64-bit) binary alongside a different version of Firefox by setting LD_LIBRARY_PATH to the custom Firefox's directory. I was unable to confirm from the user whether the version of Firefox he had installed was older or newer.

What do you think? Is there something wrong with the attempted solution (maybe a different environment variable is used now)? Is this an oddity in IceCat? Or is this maybe an upstream bug that the user on IRC didn't encounter by chance?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]