[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnuzilla] Can't get IceCat in $PATH or set as default browser.

From: Brian Durant
Subject: Re: [Bug-gnuzilla] Can't get IceCat in $PATH or set as default browser.
Date: Sat, 17 Feb 2018 18:08:10 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

OK, let's see if this works out. I have been in digest mode and as no digest arrived, I couldn't reply to your mail. Firstly, thanks for the info. I set the full path in my i3 config and it is working now. However, I have been doing some searching and tweaking, which has given me some interesting results:
1) I still can't get IceCat in my Dmenu.
2) Running icecat from the command line gives me this:

$ icecat
Could not find the GNU runtime.

3) I found that mimeopen can set defaults for a system. Mine is Devuan, no systemd Debian, so I installed "libfile-mimeinfo-perl". Then I ran mimeopen, which told me that "WARNING: You don't seem to have any mimeinfo.cache files.
Try running the update-desktop-database command. If you
don't have this command you should install the
desktop-file-utils package."

4) With this done, I ran "$ sudo update-desktop-database"
5) Lastly, I ran:
"$ mimeopen -d $file.html
Please choose a default application for files of type text/html

    1) NetSurf Web Browser  (netsurf-gtk)
    2) Geany  (geany)
    3) Icecat Web Browser  (icecat)
    4) Vivaldi  (vivaldi-stable)
    5) Xfview  (xfv)
    6) Xfwrite  (xfw)
    7) LibreOffice Writer  (libreoffice-writer)
    8) Vim  (vim)
    9) Leafpad  (leafpad)
    10) Other...
I chose #3. So that works fine as well. Now when I run "icecat" in the terminal, I get:
"$ icecat
bash: /usr/bin/icecat: No such file or directory"
Weird and still no "icecat" in Dmenu either,

I don't understand why IceCat drives the system crazy like this...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]