[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnuzilla] Impossible to install IceCat

From: Mart Rootamm
Subject: Re: [Bug-gnuzilla] Impossible to install IceCat
Date: Thu, 11 Apr 2019 10:59:19 +0300

what version of IceCat were you trying to install? Did it match the
architecture of your CPU?

What is your device make and model?

What's your device CPU architecture and clock speed, and how much RAM
memory does it have? Also, is there enough storage space to install

Why do you still have Android 4.1.2?

I have Android 4.1.2, too, so I can relate.

I've only installed IceCatMobile 52.6.0, but that install included
about a dozen add-ons that I'd never have any use for, and which
almost prevented me from using IceCat, because all those add-ons were
active by default, were chugging precious amounts of RAM (updating?),
and were nearly impossible to deactivate.

I cannot say, if these add-ons were included by upstream, or by the
package maintainer at F-Droid.

If you're worried about strange JavaScript, then you can install
NoScript. It blocks most JavaScript by default, and has a tiny
whitelist that you can clean up later on.

If you have a pre-57 version of a Firefox derivative — including
IceCat — then you can install NoScript Anywhere from


But it's quite difficult to modify that whitelist on a subdomain
level: you need to know your way around about:config, and you'll need
good knowledge of Vim (VimTouch for Android), which was once available
at F-Droid, too.

IceCat 60.x and newer require the WebExtension edition of NoScript.
It's less functional than classic desktop NoScript, but with a more
functional user interface than NoScript Anywhere. You can get that


So, anyway, in the WebExtension NoScript, you can set NoScript to
display full domains, you can clean up the built-in whitelist, you can
temporarily allow certain Google domains (if need be), and then not
worry about JavaScript at all for sites that you won't want to track
your device.

NoScript is the least-resource-intensive blocking tool.

If your device has 1 Gb or more RAM, you can also add uBlock Origin
for adblocking and for more fine-grained permissions, but it has a
steeper learning curve, and uBlock Origin does not default to blocking

For pre-Quantum Firefox and IceCat, I can recommend the following extensions:

* Console (
* Cookie whitelist for Fennec (
* Copy Profile (1.1.1)
* PageInfo Viewer (
* Privacy Settings (0.2.4)
* Proxy Mobile (0.0.10) — you can use apps that present a proxy in your device
* Stylish (2.1.1)
* View Source Mobile (

* AddCertificate (

All of the above extensions are not resource-hungry.

But these are pre-Quantum versions of extensions, and
addons.mozilla.org no longer hosts them. If you feel adventurous, then
you can search for them on the Interwebs, if you've decided on a
pre-Quantum version of IceCat.

Also, to prevent automatic updates to WebExtension versions, then in
about:config, set


to false.

Do keep in mind, that pre-Quantum versions of IceCat are less secure,
and do not have as good support for newer web standards. Many sites
may hang your browser pre-Quantum IceCat on what I see as malformed
CSS, fonts, and terrible JavaScript.

Sites that use these fonts, or which increasingly rely on CSS
variables (such as the new Skype for Web), will make pre-Quantum
IceCat Very Slow.

And if you want a device without Android, then see, if you can install
Sailfish OS.

For secure Android-based stuff, I could have at one time suggested
CopperheadOS, but its original developer was kicked out of the project
amidst deep acrimony.

Devices with non-Google Android are rare. The Nokia X family — from
before the Nokia mobile division was sold to Microsoft — is the only
such series of Android devices, but they separately promoted Nokia and
Microsoft products. Nokia X devices are now rare, and might even be
considered collector's items.


2019-04-01 23:45 GMT +03:00, address@hidden <address@hidden>:
> Hello,
> I cannot install IceCat using F-Droid on Android 4.1.2.
> The app gets downloaded and when it comes to
> installation, the required permissions are shown and I
> have to choose between "Install" and "Cancel". I tap
> "Install" (again and again to infinity) but the button
> simply doesn't respond. So I have to tap "Cancel". I
> have tried many times and it is always the same. Of
> course I have allowed installation of apps from
> external sources, that's not the issue. I have been
> able to install other apps using F-Droid.
> I tried to contact address@hidden several times but
> each time their mail server fails to deliver the
> message with a 550 5.7.1 error.
> Can you help?
> --
> http://gnuzilla.gnu.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]