[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#42475: Default DuckDuckGo search doesn't work

From: Márton Tamás
Subject: bug#42475: Default DuckDuckGo search doesn't work
Date: Wed, 22 Jul 2020 10:11:05 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Icedove/68.10.0

Dear fellow hackers,

I've been using GNU IceCat for a few years now (with great satisfaction). I've been using the DuckDuckGo Lite engine by adding their announced OpenSearch description. A few weeks ago it stopped working (the page loaded but with an empty query) but I was able to resolve this with removing and re-adding from the OpenSearch. I believe DuckDuckGo updated their site and uploaded a new OpenSearch description as well (the current description file has a 1 July 2020 "last-modified" header and "_v2" suffix in filename). So far it's a DuckDuckGo issue, IceCat has nothing to do with it (I try to contact DDG meanwhile to suggest implementing automatic updates, maybe it solves similar future issues).

While I was investigating my problem however, I also tried restoring the default search engines, and found that they all (eg. Amazon, Bing, eBay search) worked except for "DuckDuckGo Search". The exact problem seems to be that this specific search plugin/addon/extension (I'm unsure) makes a POST request, which is 302-redirected to an empty search page. The site probably accepts the search term only in a GET request. Since I haven't used this default search in a long time, I don't know if it's a new issue, but I believe it has to be fixed in one of the following ways:

The latter may be a plugin issue (not IceCat), but I can't find out what kind of component it is and who the maintainer might be. If anyone could please help by giving me directions about it, I could march along to get it fixed.

Technical details:


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]