[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#47276: Stuck at Cloudflare 'browser checks'

From: Mart Rootamm
Subject: bug#47276: Stuck at Cloudflare 'browser checks'
Date: Wed, 24 Mar 2021 23:43:50 +0200

Right-click the GitLab page, click on View Page Info, go to
Permissions tab, scroll to the Cookie section, uncheck the default,
and make sure Allow (radio button) is checked.

In some cases, there's a Tools > Page Info menu option to access the
same page properties window.

Allowing cookies like that has usually worked for most things that
have Cloudflare or other like protection from automated.

Mozilla removed cookie prompting from Firefox 44.0. This worked by
prompting to set cookies before any cookie was saved, and a user could
allow a domain, allow it for session, or block it, and then set the
permission as permanent. This also applied for third-party domains.

A developer named Savarese has continually created patches to
reinclude this functionality:

If this very important privacy-enhancing functionality were
reintroduced in GNU IceCat (including in older verisons, such as 68.x
for Android), I'd make this browser my daily driver everywhere.


2021-03-20 20:09 GMT +02:00, bill-auger <bill-auger@peers.community>:
> i dont have a solution for this; but it turned up on the
> parabola bug tracker some months ago, conflated with other
> similar issues, which affected icecat and parabola's iceweasel,
> probably since v81 - i dont believe that the problem existed
> when iceweasel was v78, so it is probably not the browser
> configuration that changed; but something gitlab.com changed
> recently
> there seems to be multiple reasons why some websites dont work -
> one of them is the "enhanced tracking protection", another is
> geo-location - relaxing those settings, did not make gitlab.com
> work though
> there are multiple tickets on the gitlab bug tracker, which seem
> to be the same problem - several suggest that it is related to
> cookie expiration; but nothing indicated a solution
> i discovered that i could make gitlab,com work with iceweasel,
> by deleting the profile under ~/.mozilla/; but that trick did
> not work for icecat - i still dont know why that website rejects
> icecat - other instances of the gitlab software work as expected
> - changing the user-agent does not help either

reply via email to

[Prev in Thread] Current Thread [Next in Thread]