[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#58011: Jitsi, Bowser, and IceCat's user agent string

From: Mark H Weaver
Subject: bug#58011: Jitsi, Bowser, and IceCat's user agent string
Date: Thu, 22 Sep 2022 22:43:28 -0400

Hi Bill,

bill-auger <bill-auger@peers.community> writes:

> On Thu, 22 Sep 2022 20:51:38 -0400 Mark wrote:
>> that my Guix-built IceCat 102 sent the following user agent string:
>>   "Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0"
> mark, would you try the "sign in" button on gitlab.com - you
> dont need to sign in - if you see the login form at all, that
> would demonstrate that the problem is resolved - with the
> "icecat" user-agent, it gets stuck on a cloudflare "browser
> check" page instead

I only spent a few minutes on it, but wasn't able to easily get the
gitlab.com sign-in page to work with IceCat 102.  It gets stuck in the
browser check page, as you said.  I tried disabling all of IceCat's
bundled add-ons, as well as the obvious IceCat-specific preferences, and
also the "privacy.resistFingerprinting" setting in <about:config>, but
it still doesn't work.

It's not immediately obvious to me what the gitlab.com sign-in page has
to do with the bug report that we're discussing here.  Have you found
that changing the user agent string fixes that problem?  If so, what
precise user-agent string have you found that works?

I'm open to the possibility that our default user agent string should be
changed to something else.  However, it would also be good to understand
why there seems to be at least one IceCat 102 build out there that sends
a different user-agent string than the one sent by the IceCat 102 built
by GNU Guix.


Disinformation flourishes because many people care deeply about injustice
but very few check the facts.  Ask me about <https://stallmansupport.org>.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]