[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#59175: GNU Icecat not loading cloudflare

From: Ruben Rodriguez
Subject: bug#59175: GNU Icecat not loading cloudflare
Date: Sun, 13 Nov 2022 20:18:44 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Icedove/102.2.2

On 11/13/22 03:01, bill-auger wrote:
On Sat, 12 Nov 2022 12:38:12 +0100 Antonio wrote:
Do you know of this GitLab bug
yes, that bug is years-old now - it has been addressed on this
mailing list; but the patches are yet to be accepted:

that mentions bug#47276 "Stuck at Cloudflare 'browser checks'"
(perhaps still open), of which this (bug#59175) is a duplicate

IceCat 102 is not set to spoof the referrer. I have tried both the methods those patches indicate, and the problem is not resolved. I have tried a long list of changes and I cannot figure out the reason, but it doesn't seem to be the user agent. A bad user agent should result in the cloudflare check failing and showing a captcha, what we have is a redirect loop. I have tested with other cloudflare-served sites and they all seem to fail the same way. I'm considering this a release blocker.

A head scratcher is that Abrowser, when loading the same settings file from IceCat, works correctly. Same for Firefox 102 ESR binaries from mozilla, suggesting that the problem may be in some other part of the IceCat build process, either in a patch or other code change; or in the toolchain, or in a library embedded at build time. My next step will be to build icecat tests with no customization, and add them in chunks, to isolate the problem. Ideas and tests are welcome!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]