[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

building groff 1.19 on Interix 3.5

From: Bob Frazier
Subject: building groff 1.19 on Interix 3.5
Date: Mon, 15 Nov 2004 13:28:23 -0800

when attempting to build groff 1.19 on Interix 3.5 I encountered the
following errors after typing 'make all'

g++ -I. -I/usr/local/src/groff-1.19/src/libs/libgroff -I/usr/local/src/groff
 -I/usr/local/src/groff-1.19/src/include -DHAVE_CONFIG_H -g -O2  -c
tmpfile.cpp: In function `FILE* xtmpfile(char**, const char*, const char*,
tmpfile.cpp:162: error: `fdopen' undeclared (first use this function)
tmpfile.cpp:162: error: (Each undeclared identifier is reported only once
   each function it appears in.)

The cause is a lack of '#define'ing either the constant  _ALL_SOURCE or

I added a definition for _ALL_SOURCE to 'src/include/lib.h' and it corrected
the problem

However, it then uncovered THIS problem:

In file included from tmpfile.cpp:22:
/usr/local/src/groff-1.19/src/include/lib.h:123: error: declaration of C
   function `int strncasecmp(const char*, const char*, int)' conflicts with
/usr/include/strings.h:68: error: previous declaration `int
   char*, const char*, unsigned int)' here
In file included from tmpfile.cpp:25:
/usr/local/src/groff-1.19/src/include/lib.h:76: error: previous declaration
   `int mkstemp(char*)' with C++ linkage
/usr/include/stdlib.h:148: error: conflicts with new declaration with C

This was as a direct result of not having '_POSIX_SOURCE' nor '_ALL_SOURCE'
defined during the execution of the configuration script.

To get it to build I had to re-extract the source (to restore it to its
original form) and pre-assign CPPFLAGS to "-D_ALL_SOURCE" before running
configure or building the project.  However, the build process then failed
when attempting to generate the first '.ps' file from the doc directory,
with a continuous unending stream of messages similar to the following:

<standard input>:1211422: warning: numeric expression expected (got `N')

while trying to do a test run by creating 'pic.ps' from doc/pic.ms .  The
number '1211422' is how many lines it printed (it began with 1 and printed
for each line, sometimes more than once).

I essentially gave up on groff 1.19, and tried with groff .  It had
the same problem requiring CPPFLAGS assigned to "-D_ALL_SOURCE".

It too exhibited an identical problem with "numeric expression expected"

I then tried groff 1.19.1 (which had not been referenced by the gnu web page
for groff, but was on the ftp site).  I did not try building it with
CPPFLAGS not defined.  Same problem occurred.  I tried allowing the 'pic.ps'
file test to complete anyway, but killed it after it had consumed nearly an
hour of CPU time.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]