[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

BUG with "module=" command

From: address@hidden
Subject: BUG with "module=" command
Date: Tue, 29 Mar 2005 19:48:07 +0200 (MEST)


I've tried loading the multiboot specification demonstration kernel
available at :
http://www.gnu.org/software/grub/manual/multiboot/multiboot.html .

Loading it caused me no problem, but I discovered that there is an issue
with the module= command. If one tries to load one module with the kernel,
everything works fine, but, with two or more modules, the informations
passed to the kernel through the multiboot structure are incorrect for the
next modules : the mod_start, mod_end and the string associated with the
module are all nulls.

This problem happens every time I try to load more than one module, for
every module but the first one.

The sources of Grub allows theoretically up to 80 modules to be loaded
with the kernel, so far I remember, therefore, the problem doesn't comes
from a hard-coded limitation.

I've looked at the code of the demonstration kernel of the multiboot
specification, and it seems me correct. I've also looked to the code of
Grub, and I found no bug at the module loading time; therefore, I suspect
an erroneous memset() or something like this is setting the rest of the
module descriptors array to 0 while booting the kernel, but that's only
a guess.

I've tried it with Grub 0.91, installed on the hard drive (of one of my
school's computers), and 0.95, installed on a CD-ROM (made with
stage2_eltorito; because grub_install was unable to find a bios
call refering the hard drive of my own box). Both tries worked the same.

Any ideas?

(Please CC' me.)



Emmanuel Colbus
Club Gnu/Linux
ENSIMAG - Departement telecoms

reply via email to

[Prev in Thread] Current Thread [Next in Thread]