[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #20627] GRUB stage1 fails on CF->IDE adapter

From: Christopher Smith
Subject: [bug #20627] GRUB stage1 fails on CF->IDE adapter
Date: Mon, 30 Jul 2007 05:07:24 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070612 Firefox/


                 Summary: GRUB stage1 fails on CF->IDE adapter
                 Project: GNU GRUB
            Submitted by: chrylis
            Submitted on: Monday 07/30/2007 at 05:07
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 0.97
         Reproducibility: Every Time
         Planned Release: 



I am building a network appliance based on a VIA EPIA-style motherboard with
a CompactFlash card for storage, connected through a generic CF to IDE
adapter.  GRUB will boot from a USB adapter but not from the IDE adapter.

I built a chroot'ed Gentoo image on my host machine and copied the install to
the CF card using a USB adapter.  I then appropriately modified the device
map, and GRUB installed successfully into the MBR.  However, upon installation
into the appliance via the IDE adapter, I just get "GRUB GRUB GRUB".

The BIOS detects the CF card reliably.  I have tried full auto-detection,
forced CHS geometry, and forced LBA; all give me the exact same error
condition.  The appliance boots to a Linux kernel successfully if I pull the
CF card out of the IDE adapter and attach it to the appliance via a USB
adapter.  Linux reports lost interrupts on hda when booting to a USB CD-ROM on
the appliance with the CF card in the IDE adapter.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]