[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #32525] Prober does not add Grub 2 boot entries for OS's on SW RAID

From: Bozo the Coder
Subject: [bug #32525] Prober does not add Grub 2 boot entries for OS's on SW RAID1 filesystems
Date: Fri, 18 Feb 2011 02:04:31 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101209 PCLinuxOS/ (2010) Firefox/3.6.13


                 Summary: Prober does not add Grub 2 boot entries for OS's on
SW RAID1 filesystems
                 Project: GNU GRUB
            Submitted by: bozonius
            Submitted on: Fri 18 Feb 2011 02:04:30 AM GMT
                Category: Installation
                Severity: Major
                Priority: 5 - Normal
              Item Group: Feature Request
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 1.98
         Reproducibility: Every Time
         Planned Release: None



When installing LinuxMint 9, which uses Grub 2 1.98, it failed to generate a
grub boot entry for the CentOS 5.5 installation already present on the disk. 
I attempted this twice in real hardware, and as I explain below, further
attempts in virtual machines under VirtualBox.

It is reasonable to expect existing OS's on RAID'd partitions to be detected
and included in the grub boot menu.  This problem persists even after
installation is complete.  Further runs of grub-install and update-grub do not
generate the missing OS.

Ultimately, I manually added entries for CentOS in 11centos, a script I added.
 Now CentOS appears on the grub menu.  This will not be up to date after
future kernel upgrades to CentOS of course.


I had the following real-world hardware configuration:

2 320 GB Hard Disks, with identical partition layouts and no hard errors as
per smartmontools:

Partition 1: swap
Partition 2: linuxmint 9 
Partition 3: CentOS 5.5 i386 (32bit)
Partition 4: LVM, mainly intended for CentOS, but for various purposes
(irrelevant, but included for completeness)

Partitions 3 & 4 are RAID 1, but 1 & 2 are non-RAID. Also, all 4 partitions
are primary type, not extended/logical.

I had CentOS 5.5 installed, up and running without any issues. The problem was
that when I installed LM9, it did not add the CentOS partition to the grub 2
menu. I went through many fits trying to get CentOS to boot again. I was able
to use rescuebootcd to restore the CentOS boot.


I've duplicated 2 scenarios under a VirtualBox dualboot VM (very sweet, saved
me a lot of headaches trying to get back to my CentOS partition in real
hardware), replicating the partitioning more or less in proportion to the
real-world hardware, laying out the virtual disk partitions in the same order
as above.

The first scenario, I didn't bother with RAID. I installed CentOS 5.5 + VBox
guest additions, no problems. CentOS boots. Then I installed VM9 and guest
additions, no problems either. CentOS shows up in the grub 2 boot menu that
LinuxMint 9 installed.  All boot entries in the menu worked.

In the second scenario, I tried the same thing, but this time simulating RAID
1 for CentOS to model what I have in the real hardware world. RAID 1 under VM
is rather slow, even on my brand-new AM3 system. With patience, the CentOS 5.5
install completed and I installed the guest additions for VBox with no issues.
CentOS booted. Then I installed VM9 with guest additions, no problems. But
this time, CentOS did not show up in the grub 2 boot menu.


It seems grub 2 WILL detect other OS's so long as they are NOT on a RAID


Of course, if you need me to contribute further by attempting additional
tests, I'd be happy to.

[Additional notes just fyi: I carefully checkpointed my VMs after getting
CentOS installed so that I could avoid having to do that again. It's fairly
simple, and I have it memorized at this point, having done it so many times
already, but still it takes a lot of time. Also, I saved both of my multiboot
scenarios in case I am requested to supply more information or run further
trials, or even export them for developer examination (after changing my


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]