[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

guile-oops bug with OpenBSD 2.6 -- caar undefined

From: Eric Frias
Subject: guile-oops bug with OpenBSD 2.6 -- caar undefined
Date: Thu, 4 Jan 2001 06:42:16 +0000 (/etc/localtime)

I can't load the goops module (from either guile or guile-oops):

Here's the transcript:
% guile
guile> caar
#<primitive-procedure caar>
guile> (use-modules (oop goops))
ERROR: Unbound variable: caar
ABORT: (unbound-variable)
guile> caar
ERROR: In expression caar:
ERROR: Unbound variable: caar
ABORT: (unbound-variable)

Type "(backtrace)" to get more information or "(debug)" to enter the

If I evaluate (use-modules (oop goops)) again, it completes without
errors, althoug caar remains undefined.

This is an OpenBSD 2.6 system, with guile 1.4 and goops 0.9.0, configured
with no special options.  I compiled the sources the same way under Linux
and it worked properly.  Any ideas?

I haven't tried this with the version straight out of CVS yet -- it looks
like it will take a bit of work to get automake/conf to play nicely with
guile on my system.  I'll get it working if need be, but I figured I'd see
if you folks have any ideas on the bug in the mean time.  I really don't
know where to *begin* to look for it...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]