[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pdf documents won't build

From: Ross Boylan
Subject: Re: pdf documents won't build
Date: Fri, 03 Nov 2006 00:48:42 +0000

On Thu, 2006-11-02 at 21:22 +0000, Neil Jerram wrote:
> Ross Boylan <address@hidden> writes:
> > I got the tarball for guile-1.6.8 and ran configure at the top level.  I
> > did this solely to get the documentation.
> >
> > When I do make pdf from the top, I get (excerpt)
> > make[1]: Entering directory `/usr/local/src/tools/guile-1.6.8/doc'
> > Making pdf in ref
> > make[2]: Entering directory `/usr/local/src/tools/guile-1.6.8/doc/ref'
> > GUILE="/usr/local/src/tools/guile-1.6.8/pre-inst-guile" 
> > ../../scripts/snarf-guile-m4-docs ../../guile-config/guile.m4 
> > autoconf-macros.texi
> > /usr/local/src/tools/guile-1.6.8/pre-inst-guile: line
> > 83: /usr/local/src/tools/guile-1.6.8/libguile/guile: No such file or
> > directory
> > /usr/local/src/tools/guile-1.6.8/pre-inst-guile: line 83:
> > exec: /usr/local/src/tools/guile-1.6.8/libguile/guile: cannot execute:
> > No such file or directory
> > make[2]: *** [autoconf-macros.texi] Error 126
> > make[2]: Leaving directory `/usr/local/src/tools/guile-1.6.8/doc/ref'
> >
> > It looks as if maybe some other stuff needs to be built first, and the
> > Makefile isn't picking up on it.
> That's correct.  It's currently the case that you need to run a plain
> "make" first.  Are you in a position to do that?
I'm not sure how much software needs to be present for a regular make. I
tried it, and it seemed to run OK.  Unfortunately, in make pdf this
seems to have advanced me to other issues:

1. The main ref manual was a no-op.  There was already a pdf file there
from my earlier attempts.  I later changed to that directory and did
make clean; make pdf.  No problems.

2. In the doc/tutorial, I got these errors, even on the 2nd run of
Chapter 4 [11]
l.945: Undefined cross reference `Scheme data representation-snt'.
l.945: Undefined cross reference `Scheme data representation-snt'.
l.945: Undefined cross reference `Scheme data representation-pg'. [12]
[14] [15] [16] Chapter 5 Chapter 6 Chapter 7 (Concept Index)

(I later changed to doc/tutorial and did make clean pdf.  The results
were unchanged.)

3. In doc/goops I got
[26] [27] [28] [29] [30] [31] Chapter 3 [32] [33] [34] [35] Chapter 4
(./goops-tutorial.texi [37]
Error: pdfetex (file hierarchy.pdf): cannot find image file
 ==> Fatal error occurred, the output PDF file is not finished!

(Same when I changed to the directory and did make clean pdf.)

Of course, all these problems might be the result of my missing some
software the build system needs (I didn't study the docs on that before
my build attempts), or having software in the wrong version.

> Thanks; we appreciate your report.  Given that there is an easy
> workaround, though, how important is this for you?
Given that I now have the 1.8 docs, which are pretty close (?), and that
these are now available in various forms on the web, not so important.

Still, it would be nice if it worked.  I suspect the problems I'm seeing
now are separate issues from the original one.

If regular make needs to be run first, perhaps the default target (or
something appropriate) should be in the prerequisites of the doc

There are a few reasons it would be good to make this work:
* the 1.6 docs are not readily available, and if you're working with 1.6
(as I guess I and other Debian users are) it's good to have the exact
* If possible, it would be good to be able to build the documentation
without having everything on hand that is needed to build the full
package.  Since I appear to have succeeded with the vanilla make, that
may already be the case.  But I have a lot of development tools on my
machine already. 
* If this is supposed to just work, maybe it indicates an automake
problem that would be good to report.
> > I'm a bit surprised you don't have people enter bugs in the bug tracker;
> > the BUGS file said to send an email like this.
> I agree that it is unusual not to use a tracker these days, but
> address@hidden is still for now our primary mechanism for reporting
> and dealing with bug reports.
You might add to the instructions that fact that you need to subscribe
to the list in order to post there smoothly; I found out the hard way. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]