[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: configure can't find libgmp

From: Marco Maggi
Subject: Re: configure can't find libgmp
Date: Sun, 9 Dec 2007 08:14:38 +0100

"Christer Jansson" wrote:
>This is the printout:
>checking for __gmpz_init in -lgmp... no
>configure: error: GNU MP not found, see README
>So I tried to compile an identical program with the same
>command and got the same result.

That is: you have composed a standalone C source holding
the code from "config.log" and GCC gave the same error?
If this is the case: we understand that it is a GCC problem
that should be fixed by GCC developers or the GNU
Autoconf developers.

I have no access to our platform, so I cannot test this. Try
asking on a MAC OS list or newsgroup. If you solve the problem
and report here, we will be thankful.

Try also the GMP documentation: they have a very well
written Info file and there should be notes in the GMP
source package.

>One other thing I find slightly mysterious is the fact that
>the source does not define any macro adding an extra
>underscore, and it only refers to __gmpz_init, but the symbol
>defined in the libs and reported as missing is ___gmpz_init.

Some platforms add an underscore to the function name
exported by libraries. Search for "name mangling". Example:


Anyway, is this of interest to you?


Marco Maggi

"Now feel the funk blast!"
Rage Against the Machine - "Calm like a bomb"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]