[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installation Error in Guile-1.8.6

From: Ahmed Majeed Khan
Subject: Installation Error in Guile-1.8.6
Date: Tue, 10 Feb 2009 12:10:52 -0500
User-agent: Internet Messaging Program (IMP) H3 (4.2)

Dear Madam/Sir,

I was trying to install Guile 1.8.6 over my machine running Fedora Core 9 at its core. Installation displayed an error that libltdl is missing and I need libltdl from libtool, at least from libtool version 1.5.6. I downloaded libtool-2.2 from the website, extracted and copied libltdl to the directory containing Guile-1.8.6 as well.

Now, when I tried installing either, libtool-2.2 or Guile-1.8.6, both displayed the same error as below:

./gen-scmconfig: error while loading shared libraries: libltdl.so.7: cannot open shared object file: No such file or directory
make [2]: [scmconfig.h] Error 127
make [1]: [all-recursive] Error 1
make: [all] Error 2

./libtool --help generated following info:

host-triplet:  i686-pc-linux-gnu
shell:   /bin/sh
compiler: gcc
compiler flags: -g -02 -Wall -Wmissing-prototypes -Werror
linker: /usr/bin/ld (gnu? yes)
libtool: (GNU libtool) 2.2.6
automake: automake (GNU automake) 1.10.1
autoconf: autoconf (GNU Autoconf) 2.61

Please tell me:
1- Do I need to install libtool-2.2 to go ahead with the installation of guile-1.8.6 or just copying libltdl is fine?
2- How to remove this error and go ahead with the installation of both, libtool-2.2 and guile-1.8.6?

Anxiously waiting reply and thanking you in anticipation.



Ahmed Majeed Khan
Graduate Research Assistant,
Wireless and Video Communications (WAVES) Lab,
Department of Electrical and Computer Engineering,
Michigan State University (MSU), MI 48823.

Phone: 517-355-8137
Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]