[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mac OS X .dylib not working

From: Peter O'Gorman
Subject: Re: Mac OS X .dylib not working
Date: Fri, 04 Mar 2011 12:07:30 -0600
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101209 Fedora/3.1.7-0.35.b3pre.fc13 Thunderbird/3.1.7

On 03/04/2011 03:44 AM, Hans Aberg wrote:
On 4 Mar 2011, at 03:59, Peter O'Gorman wrote:

The important thing is to try .dylib - all libraries I have sen use it. It can 
of course try .so as well.

Patch. Fails new testcase before (well, "new" testcase as in copy &
pasted lt_dlopenext testcase and slightly modified it), passes after.

.dylib is tried after .so so there is no potentially surprising change in behaviour for existing applications.

Oh, I forgot a NEWS entry, will add:

"On Mac OS X .dylib is now tried as well as .so with lt_dlopenext" there before pushing.



Attachment: 0001-On-Mac-OS-X-try-.dylib-as-well-as-.so-with-lt_dlopen.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]