[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-2.0.0 crash when started on MacOS X 10.6.0

From: Hans Aberg
Subject: Re: guile-2.0.0 crash when started on MacOS X 10.6.0
Date: Mon, 7 Mar 2011 11:48:01 +0100

On 6 Mar 2011, at 11:02, Andy Wingo wrote:

>> I stopped in the function, and it seems to be correct. I checked to the
>> map, and the value was right, it wasn't NULL. I tried to stop in strncmp
>> and see what that parameters were. Wasn't very successful the first
>> tried. I haven't used gdb for a while, and need to refresh it.
> The solution is to use GNU readline, not the editline-based thing that
> Apple ships.

The funny thing, though, is that when readline installs in /usr/local/lib/, it 
seems it ends up at the end of the library search path; 'man ld' says:
  Search paths
   ld maintains a list of directories to search for a library or framework to 
use. The default library search path is /usr/lib then /usr/local/lib. The -L 
option will add a new library search path.

I am not sure how to interpret this: I think that -L actually adds the new 
directories at end of the search path, whereas -I adds them at the beginning. 
That seems anyway to be the case with /usr/local/lib/ searched after /usr/lib/.

I have though checked that on my system, guile-2.0.0 links dynamically to
and not to libreadline.6.dylib or libreadline.6.dylib.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]